[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: is the Creative Labs AWE64 GOLD Soundcard supported?

     Tons of e-mail and attached files passed... Marcus and I spared those
things to others, here's what survives of the message I had started
writing for the list... 

On Sun, 12 Oct 1997, Marcus Brinkmann wrote:

> On Sat, Oct 11, 1997 at 10:14:40PM -0200, Nicola Bernardelli wrote:
> > 
> > BTW, why does the sound module say what follows at each startup, when I
> > have the default 4megs on the soundcard? (Sure, on some readme...) 
> > 
> >     AWE32 Sound Driver v0.3.3e (DRAM 28672k)
> Mmmh. Because it can't detect your soundcard correctly :)
> From /usr/src/INSTALL.awe:
> ----------------------------------------------------------------
> * Manual Installation...

... ok, I wait a moment... (it will be the last thing in this message). 

> before you do it, could you test what happens if you load a lot of samples
> with sfxload (more than four meg)? You can load the same big samples in
> different banks with:
> sfxload -b1 name
> sfxload -b2 name
> ...
> I would be interested in the error message (if any).


nick:~$ sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
nick:~$ sfxload -b1 /mnt/fat1/sb16/sfbank/2gmgsmt.sf2
[Loading Data 144]
Error in loading data: No space left on device
nick:~$ sfxload -x -b1 /mnt/fat1/sb16/sfbank/2gmgsmt.sf2
[Loading Data 144]
Error in loading data: No space left on device
nick:~$ sfxload -b1 /mnt/fat1/sb16/sfbank/2gmgsmt.sf2
[Loading Data 0]
Error in loading data: No space left on device
nick:~$ sfxload -b2 /mnt/fat1/sb16/samples/voiperpn.sf2
[Loading Data 0]
Error in loading data: No space left on device

<then I restart from scratch... After all the tweakle-hours of this
days/nights I want to listen to those demo files with drvmidi... while
recompiling 2.1.55 (done it a lot of times these last days)>

nick:~$ sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
                ^^ cleans any fonts in any bank and send this to
                   the default bank, which is 0
nick:~$ sfxload -b1 /cdrom/sf2demo/flight.sf2 
nick:~$ drvmidi /cdrom/sf2demo/flight.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/radiatn.sf2 
nick:~$ drvmidi /cdrom/sf2demo/radiatn.mid

<this one has nice use of guitar samples!... Niko Boese... Let's cut the
"standard" fonts and isolate the peculiar ones...>

nick:~$ sfxload -i -b1 /cdrom/sf2demo/radiatn.sf2
nick:~$ drvmidi /cdrom/sf2demo/radiatn.mid

<Very interesting groove (though not one of my favourite genres).>

<And... Linux is always great, no delays at all, while recompilation of
kernel 2.1.55 doesn't seem to slow down, and I have the rc5v2 client in
the background too, though it has a lower priority I think... This isn't
but a P90 single CPU.
     Linux is so robust and efficient that it may well catch more and more
the artists' attention in the future, say professional hd recording + MIDI
+ CD mastering... maybe even AudioVideo offline editing one day. And you
can bet on Debian I believe.>

nick:~$ sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
nick:~$ sfxload -b1 /cdrom/sf2demo/letmesay.sbk
nick:~$ drvmidi /cdrom/sf2demo/letmesay.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/surprise.sf2
nick:~$ drvmidi /cdrom/sf2demo/surprise.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/riffmia.sf2
nick:~$ drvmidi /cdrom/sf2demo/riffmia.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/htonight.sf2
nick:~$ drvmidi /cdrom/sf2demo/htonight.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/awedigph.sf2
nick:~$ drvmidi /cdrom/sf2demo/awedigph.mid
nick:~$ sfxload -x -b1 /cdrom/sf2demo/aweblown.sf2
nick:~$ drvmidi /cdrom/sf2demo/aweblown.mid
not a MIDI file  <------------- broken also for Windog sequencers
nick:~$ sfxload -x -b1 /cdrom/sf2demo/awegathr.sf2
nick:~$ drvmidi /cdrom/sf2demo/awegathr.mid

Anything seems OK here!


On Sun, 12 Oct 1997, Marcus Brinkmann wrote:

> On Sat, Oct 11, 1997 at 10:14:40PM -0200, Nicola Bernardelli wrote:
> [snip] 
> > Each time I did these steps (staying inside /etc and after 'mount -r -t
> > msdos /dev/sda1 /mnt/fat1' and after '/etc/init.d/nas stop'): 
> > 
> > rmmod sound
> > <modify isapnp.conf-poke and save it>
> > isapnp isapnp.conf-poke
> > insmod sound
> > sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
> > saytime
> > drvmidi /mnt/fat1/sb16/samples/awe64/*.mid
> Please, could you also try the following:
> sfxload -b1 <your-path>/sample.sbk
> drvmidi <your-path>/sfx.midi
> If you don't have those files, I would be happy to mail them to you (and I
> hope I would not violate any copyrights :( ). It is important for me,
> because it didn't worked for me the day before, but now after recompiling
> with awedrv 0.4.2c it works. (sfx.midi uses some samples in bank 1)

I have sample.sbk but not sfx.mid*

> Oh, there is another example like this coming with vienna:
> sfxload -b1 voiperpn.sf2
> drvmidi zebraper.mid
> (you shouldn't hear any piano with this, but I do....)

Try replacing any previously loaded soundfonts and putting the new one in
bank 0:

nick:~$ sfxload -i /mnt/fat1/sb16/samples/voiperpn.sf2
nick:~$ drvmidi /mnt/fat1/sb16/samples/zebraper.mid
I don't hear any piano like this ^ , while I hear it if I do: 

nick:~$ sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
nick:~$ sfxload -b1 /mnt/fat1/sb16/samples/voiperpn.sf2
nick:~$ drvmidi /mnt/fat1/sb16/samples/zebraper.mid

Notice that playing this mid file under Windog too, after loading _only_
gm35revc.sf2, resulted in _everything_ played with a piano sound. There's
a MIDI control to select a bank to select a preset in, so if a midi file
expects to have a peculiar font on a peculiar bank you have to put it
there. What is required for zebraper.mid?


On Sun, 12 Oct 1997, Marcus Brinkmann wrote:


> ... the (VERIFYLD N) command would be alot easier.

[than the POKE one, snip]

> So, if you could try this config script (note the fourth line):
> --------------------------------------------
> (READPORT 0x0203)
> (CONFIGURE CTL009e/138029808 (LD 0
> #     ANSI string -->Audio<--
> (INT 0 (IRQ 5 (MODE +E)))
> (DMA 0 (CHANNEL 1))
> (DMA 1 (CHANNEL 5))
> (IO 0 (BASE 0x0220))
> (IO 1 (BASE 0x0330))
> (IO 2 (BASE 0x0388))
> (ACT Y)
> ))
> (CONFIGURE CTL009e/138029808 (LD 1
> #     Compatible device id PNPb02f
> #     ANSI string -->Game<--
> (IO 0 (BASE 0x0200))
> (ACT Y)
> ))
> (CONFIGURE CTL009e/138029808 (LD 2
> #     ANSI string -->WaveTable<--
> (IO 0 (BASE 0x0620))
> (IO 1 (BASE 0x0A20))
> (IO 2 (BASE 0x0E20))
> (ACT Y)
> ))

As we said by private e-mail, this doesn't work with isapnptools-1.9-1; as
my system is libc5 based I had to pick the source of 1.11 in order to be
able to try with it (the Debian package depends on libc6) and rebuild the
binaries, and IT WORKS (but both isapnp and pnpdump take 6 seconds here,
while 1.9-1 took the time to press <return>). 


> * Manual Installation on USSLite-3.5.4c / OSS-Free-3.7 with Linux 2.[01].x
>   - Copy awe_wave.c, awe_hw.h, awe_version.h, and awe_config.h onto
>     /usr/src/linux/drivers/sound/lowlevel.
>     Also, copy awe_voice.h on /usr/src/linux/include/linux.
>   - Apply a patch on linux source directory, /usr/src/linux.
>     This modifies Makefile, Config.tmpl and init.c on lowlevel directory,
>     and add a help file for configuration,
>       /usr/src/linux/Documentation/Configure.help

This steps ^ are done by /usr/src/awedrv/install.sh of the debian package.

>   - If your card can't be detected automatically, edit awe_config.h and
>     supply memory size and base address for your machine.
>   - Configure and make the kernel and modules as usual.
> ---------------------------------------------------------------------
> Note the third remark. I think you have to edit awe_config.h in the
> following way:
> /*----------------------------------------------------------------
>  * AWE32 card configuration:
>  * uncomment the following lines only when auto detection doesn't
>  * work properly on your machine.
>  *----------------------------------------------------------------*/
> /*#define AWE_DEFAULT_BASE_ADDR 0x620*/ /* base port address */
> /*#define AWE_DEFAULT_MEM_SIZE  512*/   /* kbytes */
> you should change to
> #define AWE_DEFAULT_BASE_ADDR 0x620 /* base port address */
> #define AWE_DEFAULT_MEM_SIZE  4096   /* kbytes */
> Then it should work.

Done, but I still get this with kernel 2.0.30:  AWE32 Sound Driver v0.3.3e
(DRAM 28672k)

(Ok, Marcus, I still have to do it in 2.0.29... you had a message half an
hour ago... 
Britton, my dear, you understand we were doing lot of tests bringing
possibly to lot of things to be just discarded...  that's why we didn't
keep cc'ing to you... but of course the wonderful HOWTO of Marcus is

I also tried it in the 2.1.55 kernel, but there I think I should modify
something else... awe support remains more or less broken there for me (I
have a 12k text file with boot-time output of various tries I did, if you
want it I think I have better send it to you by private e-mail), almost
with the default config files, AWE_NEW_KERNEL_INTERFACE... Notice that the
debian package when applied to 2.0.30 prompts for AWE_MAX_SAMPLES,
AWE_MAX_INFOS... These questions do not appear in make config of 2.1.55...
... some days later: definitely I'll drop tweakling with 2.1.55 when I saw
there are already patches for 2.1.57 at Bigmama's! Lots of
vmlinubz-2.1.55-... tested finally removed... ahhhhhh. Now... I've found a
perl script using IPC SHMEM under /usr/doc/perl/examples... it _does_ work
with 2.0.29 and 2.0.30... and any SYSVIPC kernel I suppose... so NOW I can
concentrate on SLab. 

     Nicola Bernardelli <nbern@mail.protos.it>
     Please use <n.bern@mail.protos.it> for messages from any kind of
robot, such as mailing lists. From that address no autoresponse
messages will come, even when I am away for some days.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: