[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: is the Creative Labs AWE64 GOLD Soundcard supported?

On Sat, Oct 11, 1997 at 10:14:40PM -0200, Nicola Bernardelli wrote:
> On Fri, 10 Oct 1997, Marcus Brinkmann wrote:
> > On Fri, Oct 10, 1997 at 05:25:56PM -0200, Nicola Bernardelli wrote:
> > > Ok, for you HOWTO, I have isapnp working fine now. 
> > 
> > I find it *really* odd that you have to rearrange the order of the entrys in
> > the isapnp.conf. A *quick* and *dirty* hack, and I can't even think of
> > including it i my HOWTO (I see lots of emails complaining about such an
> > unsure statement :).
> > 
> > I can give a hint about it (and I will do), but could you check if the PEEK
> > thing from the faq works for you? Please do it for me, because the faq
> > states, that the standard does not clearly specifiy if it should work
> > without the PEEKS, means, that it is fully legitimate that you have to
> > include the PEEKS.
> > 
> > Please try it, thank you!
> Good news to you Marcus, your POKE way works fine here with the AWE64
> Gold, I tried the devices in any of the following sequences always with
> success:
> 0 1 2
> 1 0 2
> 1 2 0
> 0 2 1
> 2 0 1
> 2 1 0

Thank you, I'm happy to hear this. As I already said, I will include this in
> Each time I did these steps (staying inside /etc and after 'mount -r -t
> msdos /dev/sda1 /mnt/fat1' and after '/etc/init.d/nas stop'): 
> rmmod sound
> <modify isapnp.conf-poke and save it>
> isapnp isapnp.conf-poke
> insmod sound
> sfxload -i /mnt/fat1/sb16/sfbank/gm35revc.sf2
> saytime
> drvmidi /mnt/fat1/sb16/samples/awe64/*.mid

Please, could you also try the following:

sfxload -b1 <your-path>/sample.sbk
drvmidi <your-path>/sfx.midi

If you don't have those files, I would be happy to mail them to you (and I
hope I would not violate any copyrights :( ). It is important for me,
because it didn't worked for me the day before, but now after recompiling
with awedrv 0.4.2c it works. (sfx.midi uses some samples in bank 1)

Oh, there is another example like this coming with vienna:

sfxload -b1 voiperpn.sf2
drvmidi zebraper.mid

(you shouldn't hear any piano with this, but I do....)

Please try those, I have problems with them, they don't play correctly.
> BTW, why does the sound module say what follows at each startup, when I
> have the default 4megs on the soundcard? (Sure, on some readme...) 
>     AWE32 Sound Driver v0.3.3e (DRAM 28672k)

i don't know. This is a bug, I think. What versions of the awedrv do you
have? Did you tried the latest version 0.4.2c?

thank you for your effort, and keep going, we nearly made it!

"Rhubarb is no Egyptian god."
Marcus Brinkmann

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: