[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Clarification: Netscape install probs

kestrel@aye.net wrote:

> On Mon, 1 Sep 1997, Dave Neuer wrote:
> > Hi
> >
> > I am trying to install Netscape 3.01 on my Debian system.  The
> machine
> > running debian has no connection to the Internet, so to transfer
> files
> > to the Debian box, I have to first download them onto my PowerMac,
> and
> > then transfer them over my local network.  The mac doesn't like the
> name
> > "netscape-v301-export.x86-unknown-linux-elf.tar.gz", and so
> truncates it
> > to "netscape-v301-export.x86-unknow."  I transfered the file to the
> > Linux box, and then attempted to run the Debian netscape installer,
> and
> > got the following message:
> >
> > ERROR: The Netscape archive must be in /tmp under the name:
> >        /tmp/netscape-v301-export.x86-unknown-linux-elf.tar.[gz|Z]
> >
> >        Do NOT simply rename the archive of another version in order
> to
> >        force it to install with this package.  It will not work.
> >
> >        Archive files can be found on ftp.netscape.com.
> >
> > dpkg: error processing netscape (--install):
> >  subprocess post-installation script returned error exit status 1
> > Errors were encountered while processing:
> >  netscape
> >
> > How can I get around this, short of setting up a modem on the PC, or
> > running a DHCP program (like SurfDoubler, which is a $150 piece of
> > commercial software) on the Mac?
> >
> > Hint: I'm looking for someone who can give me detailed instructions
> on
> > editing netscape_3.01_1.1.deb's preinstallation script so that
> however
> > it's checking that the name's been changed is suppressed (since the
> name
> > is the ONLY part of the original archive that has been changed).
> >
> all you need to do is rename the file once you have it transferred to
> the
> Debian box, the message is just a warning that the package is made for
> verson 3.01 of Netscape which you got, just transfer the file and use
> the mv
> command to rename the archive and make sure it gets put in /tmp on the
> Debian machine with the full name and everything will be fine and then
> all
> you have to do is do a dpkg --configure netscape as long as you didn't
> remove the partially installed package
> G'razel the shifty kitty
> (kestrel@aye.net)
> http://www.aye.net/~kestrel
> found on Tapestries FurryMUCK

OK.  I guess I should have been clearer; I HAVE renamed the file, and
put it in /tmp.  I then run "dpkg -i netscape_3.01-4.deb" and get the
error above.  I think that I may have in fact slightly misinterpreted
the error at first; it seems to be generated by the *post*installation
script.  It seems that dpkg is installing whatever supporting files and
creating whatever necessary directories and subdirectories, and then
must be choking on the tar archive, even though I've renamed it and put
it in the proper place.  When I try running Netscape from within an X
session using fvwm's built-in application menu, nothing happens.  When I
invoke it from the command line, I get the following error:

/usr/bin/X11/netscape: /usr/lib/netscape/netscape: No such file or
/usr/bin/X11/netscape: exec: /usr/lib/netscape/netscape: cannot execute:
No such file or directory

Here is the text of the script /usr/lib/netscape/netscape:


export MALLOC_CHECK_=0

exec /usr/lib/netscape/netscape "$@"

If anyone has any ideas about what's going on with the installer, or how
I can fix this, please let me know.  I did unpack the archive myself at
one point by hand (before I found out about the installer package) using
gunzip and tar, and when I ran the netscape executable, I got the same
error message (/usr/lib/netscape/netscape: no such file or directory). 
I therefore think that there's nothing wrong with the archive itself
(aside from having been renamed at one point).  And yes, I have tried
transferring the files again to get a pristine copy of the archive on
the machine.

Dave Neuer

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: