[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

UPDATE(not fixed):xterm -ls not logging in utmp??

Brian K Servis writes:
>I noticed that when I was logging in with xterms that my login's were
>not being recorded in utmp.  I have the *loginShell resource set
>true.  So I tried a command line 'xterm -ls' and got this warning:
>Warning: locale not supported by C library, locale unchanged
>If I do 'rxvt -ls' I don't get any error and the utmp file is updated.
>What is causing the error and how do I fix it?


It turns out that StarOffice's setup script was setting the LANG variable
to 'us'  I changed it to 'en_US' as suggested in other threads and the error
went away. BUT the utmp is still not getting updated with xterm login shells.
Rlogin, rxvt, telnet all update utmp fine.  Anybody have any advice?


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: