[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ppp-off not stopping dialup-connection


My ppp-off script at one stage worked well, but now it will no longer
reset my modem while removing the ppp-link.  I do not know what I did
to cause it.  It will run and give the message "ppp0 link terminated",
but it would not reset the modem so the telephone line stays
connected.  How can I rewrite it to reset the modem?

My ppp-off script looks like this:
# If the ppp0 pid file is present then the program is running. Stop  it.
if [ -r /var/run/$DEVICE.pid ]; then
       kill -INT `cat /var/run/$DEVICE.pid`
# If unsuccessful, ensure that the pid file is removed.
       if [ ! "$?" = "0" ]; then
               echo "removing stale $DEVICE pid file."
               rm -f /var/run/$DEVICE.pid
               exit 1
# Success. Terminate with proper status.
       echo "$DEVICE link terminated"
       exit 0
# The link is not active
echo "$DEVICE link is not active"
exit 1

and my dialup script looks like this:
modprobe ppp
pppd connect 'chat -v "" ATX1DT424714 CONNECT' \
      /dev/ttyS3 57600 noipdefault debug crtscts modem defaultroute user jhspies +ua /etc/ppp/pap-secrets &
sleep 45s    #The approximate time it takes for the ISP to be ready
runq &
popclient -v 

Can somebody help please?  

Also, if there is a better way of handling the delay on the ISP side
after connection, I would like to know how to handle it.


Johann Spies

Windsorlaan 19
Suid Afrika (South Africa)
Tel. Nr. 0331-46-1310

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . Trouble? 
e-mail to templin@bucknell.edu .

Reply to: