[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /sbin/clock not ticking

I wrote:

> When I try and set the CMOS clock I get the following error:
> # /sbin/clock -u -w
> ioctl: Invalid argument

Someone kindly suggested I run "strace clock".  I am not familiar with
strace, but it did seem to give some potentially useful information.

I tried running clock on my brother's computer (also running debian) and
it works fine on his system.  I compared the strace from his clock with
the output from mine.  There were a few differences, but the most relevant

My brother's output:
open("/dev/rtc", O_RDONLY)              = -1 ENODEV (No such device)
iopl(0x3)                               = 0

My output:
open("/dev/rtc", O_RDONLY)              = 3
ioctl(3, 0x7003, 0)                     = -1 EINVAL (Invalid argument)
write(2, "ioctl: Invalid argument\n", 24ioctl: Invalid argument) = 24

I don't know what /dev/rtc is, but it seems that on my brother's computer
it can't be opened.  It seems that this in turn allows clock to work.

The strange thing is that /dev/rtc does in fact exist on my brother's
computer (and on mine).

On my brother's computer:
# ls -laF /dev/rtc
crw-rw-rw-   1 root     sys       10, 135 Jan  1  1970 /dev/rtc

All very strange.

The other thing of possible interest is that my brother's computer
opens an older version of libc.so:

open("/lib/libc.so.5.4.13", O_RDONLY)   = 3

Whereas on my computer:

open("/lib/libc.so.5.4.23", O_RDONLY)   = 3

I don't know whether this would have anything to do with it?  Any help
would be greatly appreciated.


Mark Phillips                                      mark@maths.flinders.edu.au
           "They told me I was gullible ... and I believed them!"

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: