[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Xresources (2)

i temporarily 'solved' the problem by adding the option -nocpp to xrdb in
Xsession.  But of course, now i can't use any macro's :-(. So i still
welcome all help. thx.



as a X newbee, i experimented with Xresources and succeeded setting my
preferences.  Everthing was ok for a few days.  Today i downloaded
pcmcia, booted linux, compiled pcmcia, and started X.  from then my
Xresources isnt anymore read correctly.  xrdb gives the following error
in .xsession-errors.  I also get it when i run xrdb under X from xterm:

euclides# xrdb
xrdb: cannot run '/lib/cpp -traditional -Dlinux -D__i386__
-DHOST=euclides-DSERVERHOST=euclides -DSRVR_euclides -DDISPLAY_NUM=0
-DVENDOR="The XFree86 Project,Inc" -DVNDR_The_XFree86_Project__Inc
-DBITS_PER_RGB=6 -DCLASS=PseudoColor -DCLASS_PseudoColor=32-DCOLOR
-DCLASS_PseudoColor_8=32 -DCLASS_DirectColor_8=33-DCLASS_GrayScale_8=34
-DCLASS_StaticColor_8=35 -DCLASS_TrueColor_8=36-DCLASS_StaticGray_8=37'

/lib/cpp exists (link to /usr/bin/cpp, /usr/bin/cpp exists).
xrdb -load /etc/X11/Xresources gives the same error

running the command /lib/cpp -traditional -Dlinux -D__i386__ .....
reads from stdin, after ctrl-d gives some output.  so starting the command
doesn't seem to be a problem.

can someone help?



TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: