[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86 Mouse problem on PS2 mouse.

On Fri, 4 Apr 1997, Syrus Nemat-Nasser wrote:
> On 2 Apr 1997, R. Chris Ross wrote:
> >      I recently sent a message regarding a problem that I am having 
> > with my mouse on XFree86.  The mouse is a PS2 style of Mouse Systems 
> > mouse.  According to the documentation that I have found the only 
> > setting in the XF86Config file that will work in the PS2 setting.  
> > When I run XF86Setup the only driver setting that seams to come close 
> > is the PS2 setting because the MouseSystems driver seams to only be 
> > set up for a serial mouse and this mouse is NOT a serial mouse.  I 
> > have tried quite a selection of things and am getting quite 
> > frustrated.  When using the PS2 driver the 3 buttons work fine and 
> > the mouse works fine going left to right or bottom to top.  The 
> > problem is when going the other direction, where the mouse shoots 
> > immediately to the edge of the screen.  This really is interesting to 
> > use.  The thing works perfectly fine in Win 95 so the mouse is fine I 
> > just can't get the thing to respond properly in X.  Please help.
> Hi Chris.  Are you using gpm?  I've heard that gpm should not be running 
> when running X if you have a PS2 mouse.  I also recall having a mouse 
> like you describe (same brand even) work with the same settings you 
> describe, but I did not install gpm on that machine.  If gpm is not the 
> problem, let me know and I'll look for the XF86Config file from that 
> machine.

I didn't respond to the original query because I didn't understand why 
the mouse should work for all but one particular direction.
However, I can't see why there should be a problem with running X and gpm.
I run both these with a M$ PS/2 mouse. My kernel has "Mouse support (not serial
mouse)" and "PS/2 mouse (aka auxiliary device)" compiled in (not modules)
and I have -R set in gpm. XF86Config is set to Mouse Systems protocol from
/dev/gpmdata and it all works fine.

BTW I did try running /usr/sbin/xbase-configure and liked it BUT don't
touch the mouse until after APPLYing the right protocol and device. If you
do, quit and start over; it's difficult to regain control of the screen
once a bazillion inappropriate mouse interrupts are being processed.
David Wright, Open University, Earth Science Department, Milton Keynes MK7 6AA
U.K.  email: d.wright@open.ac.uk  tel: +44 1908 653 739  fax: +44 1908 655 151

Reply to: