[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Access to NFS-server

On Wed, 5 Mar 1997, Jeff Gunter wrote:

> On Mar 5,  6:02am, Bob Clark wrote:
> >
> > cd <target_directory_on_server>
> > rsh my.pc "cd /usr; tar cf - ." | tar xf -
> >
This may work to copy the /usr-tree after installing the base disks.
But it won't solve the upcoming problem (see below).
>      root=hostname[:hostname]...
>                Give root access only to the root (uid 0) users from a
>                specified hostname.  The default is for no hosts to be granted
>                root access.
> While this does open up the possibility for someone to spoof your pc's ip
>address and mount up the filesystem, it's safer for the HP because somebody who
> breaks into the pc can't immediately hop onto the HP as root.
OK, this works when copying the /usr-tree. I moved /usr and /var/lib
to the workstation. I've done the necessary entries in /etc/fstab and
rebooted, so I come up with the small diskspace of my own computer and
the huge diskspace made available in /usr and /var/lib via NFS on
the HP-workstation.

Now I tried dselect and here we are -- me and my very old problem
(my problem is about 9 weeks old): After selecting the wanted packages
(method ftp) dselect complained: 

Approximate total space required: 28526k
Available space in debian:
Space required is greater than available space,
you will need to select which items to get.

I wanted to install only a few packages at first (that's why only 28M)
and if I call  `df' I get:

                          ...   Available ...  Mounted on
/dev/hda2                            5288      /
/dev/hda3                           74720      /var
hp.workstation:/<path>/usr        1038027      /usr
hp.workstation:/<path>/var/lib    1038027      /var/lib

It seems to be enough space to store under /var/lib where the packages
are copied to and under /usr where the packages are installed in.

The rest of dpkg's job (which was called by dselect) is a mess of
error messages. Is there anybody out there who have any idea why dpkg
is so stubborn? 

I think that the failure is caused by the special configuration with
the NFS-server. Should I send a bug report concerning dpkg or should
I look for the reason on my own boxes concerning permissions and so

I'm really helpless (and tried several times since more than two

Any further help is very appreciated


Reply to: