[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

pppd keep-alive cron script (was Re: Why is PPP so screwed up!?!?!)



> On Mon, 3 Mar 1997, Jason Costomiris wrote:
> I run myown scripts for ppp not the pon. be that as it may.. all thats 
> needed here is to make a script that greps for ppp / pon .. whatever. set
> this on a cron and bang! if the connection drops, your check script, run
> at intervals set via cron, sees it down and restarts it. 

This is what I use to keep my PPP link up. I have it in my
/etc/cron.minutely directory (same idea as the other cron.*ly dirs).

It uses two seperate tests to see if pppd is running. I've found that
under some conditions, one test or the other can fail, but the two
tests together seems to work very well.

I only created this about 28-30 hours ago, but I've tested it (unplug
phone line, turn modem off for a few minutes then back on, the usual
random disconnects, etc) and it recovers nicely. I haven't had to
manually pon since I finished it. Disclaimer: YMMV.

My modem happens to be on ttyS1. Be sure to change the S1 in the ps
args to whatever tty your modem is on.


#!/bin/sh
if [ ! -e /var/run/ppp0.pid ]
then
	if [ `ps -axwwtS1 | grep -c pppd` = 0 ]
	then
		pon
	fi
fi



Received: (qmail 26397 invoked by uid 888); 4 Mar 1997 22:33:57 -0000
Delivered-To: debian-lists--user@master.debian.org
Received: (qmail 26395 invoked by uid 888); 4 Mar 1997 22:33:57 -0000
Delivered-To: debian-user@lists.debian.org
Received: (qmail 26388 invoked from network); 4 Mar 1997 22:33:56 -0000
Received: from tinuviel.cs.wcu.edu (mail@152.30.5.1)
  by master.debian.org with SMTP; 4 Mar 1997 22:33:55 -0000
Received: from localhost (jkillen@localhost)
	by tinuviel.cs.wcu.edu (8.8.5/8.8.5) with SMTP id RAA13129;
	Tue, 4 Mar 1997 17:25:42 -0500
Date: Tue, 4 Mar 1997 17:25:41 -0500 (EST)
From: Jason Killen <jkillen@tinuviel.cs.wcu.edu>
To: "( Don )" <dxg6153@megahertz.njit.edu>
cc: debian-user@lists.debian.org
Subject: Re: help
In-Reply-To: <331C603B.2998@megahertz.njit.edu>
Message-ID: <Pine.LNX.3.95q.970304172414.13085A-100000@tinuviel.cs.wcu.edu>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII

I got some stuff like this and it ended up that something had killed init.

I also get some weird things, sorta like this, when I load the sysv module.
To fix that I recompile and check my modules setup, that was a while ago
so I don't really remember.


On Tue, 4 Mar 1997, ( Don ) wrote:

>hi 
>i just tried 2 boot up my debian linux partition and i got this.
>first of all it begins 2 load the first half of the kernel and then i
>get this error no matter if i boot from a floppy ar from my hard
>drive.HELP PLEASE
>
>Unable to handle kernel NULL pointer defernce at virtual address
>c00004e0
>current->tss.cr3 = 00101000, %cr3=00101000
>*pde=00102067
>*pte=00000027
>Oops: 0000
>CPU: 0
>EIP: 2048: [<0000C68d>]
>EFLAGS: 00010046
>eax: 0000530 ebx:000001ff ecx:000080ff edx:0000ffff
>esi:00009fdc edi:00000000 ebp:0000040a esp:00009f20
>ds:2050 es:0000 fs:0000 gs:0000 ss:0018
>Process swapper(PID:1, process n:1, stackpage=00009000)
>stack: 0000c595, 00010000, 530....."and lot's of #'s"
>Call Trace: [<001732af>] [<00110018>] ....and more #'s
>Code: a0 e0 00 c3 e1 00 c3 a1 e2 00
>      c3 00 c8 02 00 00 57 56 33
>Started kswapd v 1.4.2.2
>
>
>and then it freezes and nothing happens after that?   is there any way i
>can salvage this? maybe if i set up a linux partition on a separate hard
>drive do u think i'll b able to access this one?  thank u
>                                dOn Guelich
>


Jason Killen                            Question Stupidity
Monolith : driven by inner daemons      RPS : better living through world
jkillen@tinuviel.cs.wcu.edu                domination

     


Reply to: