[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Writing to a boot floppy. ( /dev/fd0u1440 anyone?)

> I recompiled my kernel today (without any major problems) to 2.027,
> however, I can't seem to figure out how to create a new boot floppy.  I have
> tried:  cp vmlinux /dev/fd0 to a DOS-formatted disk, but when I tried to reboot
> my computer, it didn't work.  

Have you tried :

  cat /vmlinuz > /dev/fd0

yet? That works just fine for me. The floppy has to be formatted of course.
Some manuals also mention:

  dd if=/vmlinuz of=/dev/fd0 bs=8192

as a method for doing this.

However, that does not always work fine for me. I figure this has something 
to do with my /dev directory filled with /dev/fd0u* devices instead of /dev/fd0h* 
(e.g. I have a /dev/fd0u1440 instead of a /dev/fd0h1440 on my system.) 

I guess this is a weird bug on my 1.1.4 system (Infomagic september cd) and it 
is pretty annoying because it tends to break scripts like in the kernel-package. 

When I succeed in better pinpointing the circumstances that produce these 
lethal exceptions, I will try to ask a more specific question about this on the list. 

Anyone who knows of or has dealt with this? Please let me know.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: