[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: g77 problems

Kaj Wiik wrote:
> When trying to run g77 on 1.2 I get
> gcc: installation problem, cannot exec `f771': No such file or directory

Hehehe, I fought with this for awhile - there are a lot of 
dependencies I don't fully understand, but here is what worked
for me (these weren't "blind" changes, sorta educated guesses):

gcc seems to use the files in 
/usr/lib/gcc-lib/i486-linux/, but the f771 was installed in
....../2.7.2.  So, the solution seems to be a simple link (actually

     cd /usr/lib/gcc-lib/i486-linux/
     ln -s /usr/lib/gcc-lib/i486-linux/2.7.2/f771 f771
     ln -s /usr/lib/gcc-lib/i486-linux/2.7.2/libf2c.a libf2c.a

This worked for me, and I've been able to compile some real heavy-duty
code.  I don't fully understand these dependencies, though, so I'd
appreciate it if someone would tell me (or all of us) if I did a
stupid thing.

Also, if you installed "gnat" (not "gnats"), you may find that gcc
won't work anymore - I'd recommend un-installing this if, like me, 
you don't fully understand what's going on - again, works for me,
but I don't understand the whole picture...


   Don Morton                          donm@cameron.edu              
   Department of Math Sciences         Voice (405) 581-2396          
   Cameron University                  Fax   (405) 581-2616          
   Lawton, OK 73505                http://www.cameron.edu/~morton

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: