[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hda3 won't mount as root - ok on /mnt - ??? HELP!

> Ouch! Still same problem.
> Tried to upgrade from 1.1 to 1.2 (selecting multiple items in 
> deselect). The install bombed, kernel panic, (probably disk space?). 
> I had to use the reset switch. Now no boot. The partition containing 
> only /var (with deb files of course) was corrupted. All other partitions 
> checked out ok.
> When trying to boot, lilo loads the kernel ok. Kernel does initial 
> checks. The console displays "VFS: mounted root (ext2 filesystem) 
> readonly", then nothing. Keystrokes are echoed to screen, but init 
> never starts. CtlAltDel works to reboot to the same thing.
> Booting from floppy I can mount hda3 (my root) on /mnt. Yes, I 
> e2fsck'ed it, and it passes. Re-ran lilo (ROOT=/mnt /mnt/sbin/lilo), 
> went ok, but still no hda3 mount as root.

I don't get it. You are saying that
  mount -t ext2 /dev/hda3 /mnt
works, but
  mount -t ext2 /dev/hda3 /

If that really is the case, just do
  mount -t ext /dev/hda3 /mnt
  cd /mnt; chroot . ./bin/bash
and your /mnt will be "/" for the process you just started. Then you can continue
just like you'd otherwise do if the mount on / did go ok.

But really, it all seems somewhat strange to me,

joost witteveen
Use Debian/GNU Linux!

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: