[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fdisk errors

I have recently created a small (16MB) ext2 partition on the same hard
drive where I have my root Linux partition.  Today, I tried to delete it
if with fdisk, since I don't need it anymore, but after I exit the fdisk
with the "w" option, and it is done syncing disks, I get the following
error: "Reread table failed with Error 16: device or resource busy."  As
a result, the partition stays there, even after reboot.  Also I tried
running partinfo.exe--a DOS utility that prints the partition table
(comes with Partition Magic).  It gives me a more interesting error: 
"logical drive chain extends toward start of drive.  This is
incompatible with DOS fdisk. Linux fdisk is one source of this
problem."  How do I go about getting rid of the problem?  It is not as
much the space that I need, but now I can't use Partition Magic to
manipulate my DOS partitions, which is very useful.  BTW, the partition
is the last logical drive--/dev/hda8.  Could this have something to do
with the problem?  I appreciate any help you could give me.  Please let
me know if there is a better mailing list for this kind of problem.

Proudly running Debian Linux! Linux vs. Windows is a no-Win
Igor Grobman                                             igor@vaca.net

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: