[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg-ftp problems (dselect and kernel source package)... (longish)

Assuming that this is the correct group to ask this type of question,
could someone help with a couple of problems I'm having with Debian
First, dselect (which generally works very well), appears to have become
broken somehow -- I can no longer change the Access method to use. If I
try, I get the following:
syntax error at /usr/lib/dpkg/methods/ftp/setup line 112, near "print"
Execution of /usr/lib/dpkg/methods/ftp/setup aborted due to compilation
query/setup script returned error exit status 2.
Press RETURN to continue.
Secondly, also with dselect, when I get new packages via FTP, they
download correctly, but with the following message first:

Downloading files... use ^C to stop
Connecting to ftp-uxsup.csx.cam.ac.uk...
Login as anonymous...
Setting transfer mode to binary...
Cd to /pub/debian...
getting: frozen/binary-i386/admin/dftp_2.1-1.deb
Not a GLOB reference at /usr/lib/perl5/IO/Handle.pm line 285, <STDIN>
chunk 2 (#1)
    (F) Perl was trying to evaluate a reference to a "type glob" (that is,
    a symbol table entry that looks like *foo), but found a reference to
    something else instead.  You can use the ref() function to find out
    what kind of ref it really was.  See perlref.
Finally, (sorry for the length of this!), I can't get the .deb of the
kernel 2.0.23 to work. dpkg -i returns:
# dpkg -i kernel-source-2.0.23_0.deb 
(Reading database ... 30437 files and directories currently installed.)
Unpacking kernel-source-2.0.23 (from kernel-source-2.0.23_0.deb) ...
dpkg: error processing kernel-source-2.0.23_0.deb (--install):
 corrupted filesystem tarfile - corrupted package archive
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:

I've tried downloading from both the local Cambrdige mirror and Sunsite at
Imperial College, checking binary mode, etc., and I still get this. I
*have* noticed that dselect shows the Avail. Ver. as 0 for this package --
presumably this is wrong? 

Thanks for any help,

Richard Mortier, Churchill College, Cambridge
rmm1002@cam.ac.uk (preferred) or mort@spuddy.mew.co.uk
"Life is a near-Death experience" Terry Pratchett, a.b.p

This message was distributed manually by Bruce@debian.org after the list
initially failed to distribute it.

Reply to: