[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Boot up problem...


I have a problem on boot up that I don't understand and can't seem to fix.
I have installed Debian 1.1 (off the latest infomagic cd's).  The first 3
computers I installed in on worked fine.  This one is an older computer, a
386 dx 40 with 4 MB of RAM and 16450 UART's.

The install seemed to go fine without any errors, yet when I boot up I 
get this:

  Configuring serial ports....done.
  /dev/cua0: No such device
  /dev/cua1: No such device
  /dev/cua2: No such device
  /dev/cua3: No such device
  INIT: Entering runlevel: 2

I traced the problem down to /etc/rc.boot/0setserial, I read the script
(removed all the stuff I don't need) and manually defined the com ports.
The error persisted.

I have tried putting a sleep 5 in before the:

  ${SETSERIAL} -bg /dev/cua*      

line which is reporting the problem and that didn't make any difference.

I check the /dev directory and as far as I can tell it all looks okay, and
I can make a PPP connection no problem.

mis(larry)> l /dev/cua*
crw-rw----   1 root     dialout    5,  64 Nov  7 21:29 /dev/cua0
crw-rw----   1 root     dialout    5,  65 Jan  1  1970 /dev/cua1
crw-rw----   1 root     dialout    5,  66 Jan  1  1970 /dev/cua2
crw-rw----   1 root     dialout    5,  67 Jan  1  1970 /dev/cua3

The weirdest thing of all is if I run the script as soon as I get a prompt
then it works fine!

mis(larry)# /etc/rc.boot/0setserial
Configuring serial ports....done.
/dev/cua0 at 0x03f8 (irq = 4) is a 16450
/dev/cua1 at 0x02f8 (irq = 3) is a 16450

Any comments or suggestions appreciated.



--------------- Earthlight Communications Limited ---------------
P.O. Box 5301              Adam Shand        (fax) +64 3 477 5463
Dunedin, New Zealand    Systems  Manager   (voice) +64 3 479 0303
----------- http://www.earthlight.co.nz/homepage.html -----------

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: