[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gzip and dpkg problem

   OK, haven't done much yet, but here's what I've done to check the 
getty/gzip/dpkg problem. 

 On Thu, 6 Jun 1996, Ian Jackson wrote:

> This is a bug in one of:
>   Your inetd, telnetd, rlogind, if you're logging in over the
>     network (some versions of the Debian netbase and/or netstd
>     packages had this problem).

   I've never tried to use dpkg this way.

>   Your shell (I know of no shells that cause this problem).

   I'm using bash, so if it's bash I'm really screwed... but it's not 
(keep reading)

>   The getty you're using.
>     (Some versions of getty_ps are known to have this problem.)

   This looks like the problem! OK, I can't try this on the computer I 
mentioned in my first message, cause I had to have it running so I 
plopped slackware on it-will put debian back on tonight. So instead, on 
my other debian comp, here's what I did:

 my /etc/inittab
1:2345:respawn:/sbin/agetty 9600 tty1
2:23:respawn:/sbin/agetty 9600 tty2
3:23:respawn:/sbin/getty_ps tty3 9600 linux
4:23:respawn:/sbin/getty_ps tty4 9600 linux
5:23:respawn:/sbin/getty_ps tty5 9600 linux

So using both, here's what happened:
cat /dev/zero | true
 on tty1 and tty2 : got "Broken pipe" error msg
 on tty3+ : got "cat: write error: Broken pipe" error msg

using dpkg to install samba-1.9.14.deb (this was the package I was trying 
to install on the other computer that prompted my 1st message)
 on tty1 and tty2 : did ok
 on tty3+ : got same error message about gzip -dc

so this looks like fairly conclusive evidence for me.

>   The login you're using (I know of no problem here).

Can't help there. Except for the getty differences, I'm just using bash 
on a tty, no su, no telnet, nothing special.

>   Any program which started one of the above, or which is in
>     the calling chain for dpkg.

Can't help again.

OK, there was also a message about this problem happening in an xterm/rxvt
I tried using tcsh as root in an xterm and did get errors, but that was
due to my tcsh configuration errors rather than the one that gives you the
gzip -dc error message. So I can't really say whether this would be the
same type problem as mine. I'm very ignorant about all the inner workings
of terminals, getty's, etc., so I did try launching X from both agetty and
getty_ps, but that didn't seem to matter either. 

Well, from my end, the getty issue seems to be where the problem was 
coming from. Thanks for everyone's help! That problem was really bugging 
me. If anyone has any other tests they'd like for me to run, just let me 
know and I'd be happy to help.

-Paul Schoenly
Auburn University

Reply to: