[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

big problems with installation

  I have an old AMD' 80386 40MHz with 4MB of RAM and I really like
to install Linux on it. I spent some time looking around and
then I decided to proceed with the Debian distribution.
Got the five disks of the 0.93R6 version I started the installation 
but with no success at all.
I disabled all the option for shadowing ROM and I deleted all
the data on the HD (Conner CP30104 121MB) before to start.
Then I ran the boot and root disks (created with dd ...).

The first problem was with some screens of the installation
program that didn't appeared at all (I mean the only thing on the 
video was the cursor blinking). Anyway by pressing return twice I 
finally went to the Custom section. I did partition the HD and then
prepared swap and linux partition. Then I mounted / and selected
the option for installing debian. System ask to put the boot disk
in the FDD and then dump something like a 'core' and stops.

Here is some interesting data:
- Boot messages
> Memory available 1036/4096K (900K kernel, 384K reserved, 1776K data)

- Part. Table
> hda1 type 83 102316+ blocks 99.94 MB
> hda2 type 82  16536  blocks 16.15 MB

- Core (?!?)
> Ooops:  0002
> EIP:    0010: 00118efd
> EFLAGS: 00010202
> ...(lost the paper, sorry)...
> Process swapper (pid: 0, process nr: 0, stackpage=001e073c)
> Stack: 001e26ac 00094800 00000004 0011eea6 00000000 00112c7e 00000000
> 001e26ac 001119c6 00000000 001e26ac 001e2774 001e2774 001e2774 00094800
> 00101ffc 00000000 00000002 ffff0018 00110018 ffff002b 00000018 fffffffe 
> 0010f8dc
> Call Trace: 0011eea6 00112c7e 001119c6 00110018 0010f8dc 00110749
> 0010f3b7 00118314
> Code 89 42 41 e2 04 01 c2 01 d2 01 15 30 3a 1e 00 c1 2d 30 3a 1e
> Aiee killing interrupt handler
> hfree of non k-malloced memory 001e2734
> next=00000000 order=0
> task[0] (swapper) killed: unable to recover
> kernel panic: trying to free up memory space
> In swapper task not syncing

Well, let me say that I've tried at least 4-5 more time,
using Novice mode too, but sooner or later the process
stopped (some time it was when mounting the filesystems, 
some time it printed out some message like 
"sed: Couldn't allocate memory" or "cut: Virtual memory exhausted")

Anyone can help me? (Please not telling me to buy 4MB of RAM...)
By the way my BIOS is an AMI dated 12/12/91.

Thanks in advance and sorry for my awful english.
Alberto Brizio (brizio@cstv.to.cnr.it)

Reply to: