[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

4 Meg ram install kind of worked.

     I recieved the following message which got me thinking in a bit 
different direction.  

>To: R Chris Ross <CHRIS@seitz.com>
>Mr Chris Ross
> Maybe the solution to your problem is that you should try the 
>installation in two steps:
> repeat the normal installations as you followed last night until you
>prepares the hardisk an put ON THE SWAP partition. 
> Then restart again your pc with a floopy with booting system 
>(I mean that that allow you to mount your / partition directly without
>lilo, I don't know if it possible to you build one from the step one)
>and then install the rest of the base system. The idea is try to
>reboot the machine allowing linux to put on the swap from the hardisk
>an then you have the oportunity to install the rest... A similar
>procedure I used time ago when I try to install slackware in a 4MB PC.
>The difference was that previously to the installation slackware allow
>us to use the command swapon.. I'm new in unix-linux, but I hope this
>can help you a little. avelino

     Since I had a formatted swap and main linux partition I had 
someplace to operate.  After booting from floppy again with 
"linux load_ramdisk=0" and getting to the install menu on the root 
floppy I shelled out and used ae to add a starting line to /etc/rc to 
activate my swap partition ( swapon /dev/hda4).  At this point I 
rebooted and ran the install normally with the ramdisk.  The 
installer had to be tricked a bit by telling it that I didn't want to 
use swap space which, it said was a bad idea then I could have it 
mount the ext2 partition that was already there. (This partition was 
made while running with the floppy as / during a previous session.)  
After the main partition was mounted and made / I tried loading the 
base.  This I crashed once because I was using the color install 
screend.  When monocrone was used the base loded and attempted to 
uncompact.  As far as I can tell this functioned properly.  Due to my 
own stupidity I had picked us 1 base dated April 27 and 2 dated 
April 18.  The mirrors were out of sync and I didn't think to check 
the dates.  
     Shortly I'll pick up a single set of base floppies and give it a 
shot again.  If there is something that I should do to clean out the 
bad install I did please let me know.  From what happened at the end 
it looks like it should load fine.
     Thanks for the help.


Reply to: