[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unidentified subject!


This plea for help comes from a relatively new convert to Debian. 
I too express my appreciation to the Debian-folks, having
seen how well organized and tightly integrated this system is. 

Now to the problem. I want to hook up a dumb terminal to my Debian
PC. I started with Greg Hankin's Serial-HOWTO (v1.8, dt. 28 Mar 1995)
At the start I found the following files missing in my Debian system.

	(i) /etc/gettydefs
	(ii) /etc/conf.getty.ttyS(0-4)

Also the man page for getty talks about agetty(8). agetty, however,
is not to be found in /sbin.

Despite these I went ahead and did the following:

	o connected the dumb terminal to ttyS3

	o included the following line in /etc/inittab

	  S3:456:respawn:/sbin/getty ttyS3 DT9600 vt100

          (ttyS3 was used because the other available serial port
           was ttyS1 to which I had connected the mouse. The setserial
           command on these devices produced the foll. output

     	   /dev/ttyS1 at 0x02f8 (irq = 3) is a 16450   
	   /dev/ttyS3 at 0x02e8 (irq = 3) is a 16450   

	o I did

          bash# telinit 4


	  bash# init q 

	  did not do anything (I mean it did not change the runlevel 
	  as I expected it to)

At this time I should have seen the login prompt at the dumb terminal
side, which I did not. However after a few minutes the following message
appeared on the console.

INIT: Id "S3" respawning too fast: disabled for five minutes

The Serial_HOWTO tells me this is due to :
  15.3.  I keep getting ``Id SN respawning too fast: disabled for 5 min-

  Make sure your modem is configured correctly.  Look at registers E and
  Q.  This can occur when your modem is chatting with getty.

  Make sure you are calling getty correctly from your /etc/inittab.
  Using the wrong syntax or device names will cause serious problems.

  This can also happen when the uugetty initialization is failing.  Go
  to the ``getty or uugetty still doesn't work'' question.
 15.11.  getty or uugetty still doesn't work.

  There is a DEBUG option that comes with getty_ps.  Edit your config
  file /etc/conf.{uu}getty.ttySN and add DEBUG=NNN.  Where NNN is one of
  the following combination of numbers according to what you are trying
  to debug:

  D_OPT   001            option settings
  D_DEF   002            defaults file processing
  D_UTMP  004            utmp/wtmp processing         
  D_INIT  010            line initialization (INIT)
  D_GTAB  020            gettytab file processing
  D_RUN   040            other runtime diagnostics
  D_RB    100            ringback debugging
  D_LOCK  200            uugetty lockfile processing
  D_SCH   400            schedule processing
  D_ALL   777            everything

  Setting DEBUG=010 is a good place to start.


	I think that I am calling getty correctly

	Could the problem occur because I do not have a /etc/conf.getty.ttyS3
file? (Why are these files and agetty missing in the Debian distribution)

	Thanks in advance for any help in this regard.

Saji N H                                  
Research Student                          
Centre for Atmospheric Sciences      e-mail: saji@cas.iisc.ernet.in
Indian Institute of Science
Bangalore 560 012

Reply to: