[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: diald & pppd trouble query

Richard Tietjen wrote:
> I believe I tried ttyS3 instead of cua3 to no avail.  

Make sure. Changing from cua0 to ttyS0 solved my problem which had
identical symptoms.

> It seems as if
> pppd is not getting invoked once chat makes contact.  When I looked at
> the stdout of diald in -daemon debug 31, I saw the puzzling message:
>    Sorry - this system lacks PPP kernel support

This message is reported by pppd, after a failure of the ppp_available()

> kale:~ # diald /dev/cua3 -m ppp -f /etc/diald.options -- /dev/cua3

Given your configuration, I recommend the following:

kale:~ # diald /dev/ttyS3 -f /etc/diald.options

You should pass nothing (unless you have special settings for your
terminal server) to pppd when using diald. All the ordinary options are
specified by diald when pppd is invoked. For example, passing the serial
port after the -- doesn't look like a good idea.

I don't know the all the reasons, because I am still waiting for the
author's explanation.

I will quote Eric Shenk's (diald author) response to my problem so that
you can try out his other suggestions if the above fails.

Hmm. There were some messages about this kind of problem floating
around on the linux-ppp list a while back. I seem to recall two
possible causes:

(1) The new pppd is installed in a different place than the old,
    are you sure diald is running the new pppd? Check the path
    in config.h. [I expect this is not your problem, but check it

(2) There were reports of a problem when starting pppd from inittab.
    This was a result of pppd relying on having a controling terminal,
    which it does not when started from inittab. This problem may
    be related to what you are seeing. The way the test code is written
    the ppp_available routine would fail if it was run and it could not
    actually open /dev/cua0.

        Check the following:
        the permissions on /dev/cua0.
        that you are running diald as root.
     You might also try running diald with /dev/ttyS0 instead (this is
     a shot in the dark, but it's worth a try).
     If any of this works I'll be happy to explain why :-) If it
     let me know and I'll give you instructions for buckling down with
     gdb to figure this thing out.


Jeffrey Ebert-------------------------------------jebert@ix.netcom.com
------------------Powered by Debian GNU/Linux-------------------------

Reply to: