[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem detecting cd-rom

I just installed debian using novice mode on a Compaq 9564 (P133Mhz) and 
it was not able to detect the cd-rom. The documentation does not mention 
the brand of the CD-rom. With help from Matt(Compaq) and Compaq support,
I have narrowed the type of CD-ROm to either a Panasonic or a Sony.

The installation was able to detect most everything else with the 
exception of this note in /var/adm/messages, 
Serial driver version 4.11 with no serial options enabled.

The other error message referred to the cd-rom. Note, I tried installing 
once with each of the three cd-rom options.

I looked through the troubleshooting section of the CDROM Howto and 
checked the following,
cat /proc/devices
Character devices:
 1 mem
 4 tty
 5 cua
 6 lp
 7 vcs
10 mouse

Block devices:
 1 rd
 2 fd
 3 ide0

cat /proc/filesystems
nodev proc
nodev nfs

cat /proc/ioports
0000-001f: dma1
0020-003f: pic1
0040-005f: timer
0060-0060: kbd
0064-0064: kbd
0070-007f: rtc
0080-009f: dma page reg
00a0-00bf: pic2
00c0-00df: dma2
00f0-00f1: npy
01f0-01f7: ide0
02f8-02ff: serial (set)
0378-037a: lp
03d4-03d5: ega+
03f6-03f6: ide0
03f8-03ff: serial (set)

Of course when I tried to read from the cdrom with dd, it didn't know what 
/dev/cdrom was and therefore couldn't mount the cdrom.

Any ideas?

If I ever get the cd-rom problem resolved, what is dselect expecting me 
to answer when it asks for base address in the first option for your 
source of installation? "/dev/cdrom" ?


Reply to: