[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: terminal problems with emacs

Matthew Swift writes:

>The problem is I can't use ange-ftp because the terminal process is
>screwy and can't be parsed properly.  When I try to open
>"/swift:acs:", I type in my password, and it connects, but then dies
>because it can't parse the ftp buffer, which looks like this:

At a guess this has to do with the readline support in the ftp client.

To work around the problem, set the variable ange-ftp-ftp-program-name
to "dumbftp" and create a program called dumbftp somewhere in your

unset TERM
ftp "$@"

Remember to make it executable.  This solved the problem for me with
19.28-3, which is a bit old now...  I don't know if the bug is present
in the latest Emacs.

I tried setting ange-ftp-ftp-program-name to "TERM=dumb ftp" but Emacs
wasn't having any.

>  popclient: clearbiffbit: fchmod: Operation not permitted
>  popclient: restorebiffbit: fchmod: Operation not permitted
>I tried to see what's going on with strace, but I could not add
>anything to the above information: sure enough, in the one case an
>fchmod() call fails.  The file descriptor that fchmod() operates on is
>0 in both cases, but I can't find an open() that returns 0 -- is zero
>the stdin? 

I also find this occurs in some situations.  0 is indeed stdin.  I
assume there is some convention somewhere that one sets the execute
bit on a terminal to indicate that mail has arrived, though I know
nothing about that.

IME the presence of the messages doesn't seem to stop anything


Reply to: