[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems with elv-vi package install



On Wed, 27 Sep 1995, Zachary DeAquila wrote:

> 
> I tried to installt he elv-vi package and got this:
> 
> ---snip-snip-snip--
> 
> zachs:/binary/editors# dpkg --install elv-vi-1.8pl4-16.deb
> Selecting previously deselected package elv-vi.
> (Reading database ... 9882 files and directories currently installed.)
> Unpacking elv-vi (from elv-vi-1.8pl4-16.deb) ...
> Setting up elv-vi ...
> /var/lib/dpkg/info/elv-vi.postinst: update-alternatives: command not found
> dpkg: error processing elv-vi (--install):
>  subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
>  elv-vi
> 
> ---snip-snip-snip--
> 
> Like any good linux hacker, I then poked at the script in question
> (/var/lib/dpkg/info/elv-vi.postinst)
> 
> And, sure enough, it's expecting a command called 'update-alternatives', that,
> as far as I can tell, is supposed to make some symbolic links.  Should I already have this
> program? is it a packaging problem?  I'm using dpkg 0.93.70, which is pretty cloe to the latest,
> as I recall.
> 
> help?
> 
>  --Zachary
> 
> 
I had problems updating elv-vi also. In addition to what Andrew mentioned 
about upgrading dpkg you also need /debian/binary/devel/perl-5.001-3.deb 
installed in  order for update-alternatives to run correctly. Needs files 
from /usr/lib/perl5 such as "POSIX.pm".
 __
Dick

 Dick  Arnold            *****************************    
 2015 N. 8th St.         |   Debian GNU/Linux 0.93   |    Ph. 217-528-8918
 Springfield, IL 62702   ***************************** 


Reply to: