[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problema activando swap desde el inicio



Buenas tardes, otra vez por aquí, un saludo cordial a todos los que
dan vida a esta prodigiosa lista...

Tengo una duda que no he podido resolver, tal vez es algo que me he
pasado por alto.

Estoy con un desktop de mi laboratorio de investigación, tiene
instalado Windows XP con 2 particiones (C y D) en un sólo disco de 40
GB. Como contiene datos sensibles de varios usuarios dejé éste sistema
instalado.
A la máquina le monté otro disco duro de 10 GB donde instalé un Debian
6 mínimo con el punto de montaje /  en una partición de 4. 7 GB y
/home en otra partición de 4,88 GB. Para usar todo el espacio
disponible, la swap la monté en una tercera partición primaria que la
metí en el disco de 40 GB.
El problema es que al arrancar el sistema, la swap no se activa en el
inicio, y debo montarla manualmente por terminal o con GParted, y ya
estoy cansado de eso.

En resumen:

Primer HD (40 GB):
/dev/sda1   fat32           Windows XP (C)    27.95 GB
/dev/sdc1   ntfs             Windows XP (D)     9.22 GB
/dev/sdc2   linux-swap      swap                  2.01 GB

Segundo HD (10 GB):
/dev/sdb1   ext4            /                           4.66 GB
/dev/sdb2   ext4            /home                   4.88 GB


La orden "cat /etc/fstab" me arroja esto:

# / was on /dev/sdb1 during installation
UUID=1c6828d1-f750-42a6-9497-7578167eb9b2 / ext4 errors=remount-ro 0    1
# /home was on /dev/sdb2 during installation
UUID=11d3c73b-3061-4d0e-a9a0-abcc7a188ffc  /home ext4 defaults       0    2
# swap was on /dev/sdc2 during installation
UUID=8b66-7725-4580-4db3-a2fb-1fa01274c38a  swap   swap defaults    0    0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0


La salida del comando "blkid" me dice:

/dev/sda1: UUID="3463-438F" TYPE="vfat"
/dev/sdc1: LABEL="Disco local" UUID="1695858E18782B64" TYPE="ntfs"
/dev/sdb1: LABEL="Debian-GNU/Linux"
UUID="1c6828d1-f750-42a6-9497-7578167eb9b2" TYPE="ext4"
/dev/sdb2: LABEL="Debian-home"
UUID="11d3c73b-3061-4d0e-a9a0-abcc7a188ffc" TYPE="ext4"
/dev/sdc2: LABEL="Intercambio"
UUID="8b667725-4580-4db3-a2fb-1fa01274c38a" TYPE="swap"


El comando "free -m" me arroja:

               total       used       free     shared    buffers     cached
Mem:        502        474         27          0         2      134
-/+ buffers/cache:     318        183
Swap:           0          0          0



GParted me da la opción de "activar la swap", es decir, que no fue
activada desde el inicio.


Gracias por adelantado quien pueda ayudarme a vislumbrar una solución.
Reply to: