[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLUCIONADO] ayuda sobre virtualhost apache2



Marc escribió:
En/na pizzakiller ha escrit:
On Wednesday 01 July 2009 13:57:07 darias wrote:
  
zoneclient.py: No address found on router.
 apesar de eso logro entrar x ssh y x el browser responde asi q no tengo
idea. q puede ser lo q falla.
    

bueno lo que se me ocurre es que apache no esta toamdo en cuenta tus 
archivos donde defines los VirtualHost o no puede conseguir la ruta
verifica mayusculas espacios en blacno carateres raros

o qaue no tienes un index.php o index.html 
o deberias definir en tu VirtualHost
DirectoryIndex "aqui pones el archivo que necesitas que inicie (sin comillas)"

verifica los permisos de las carpetas ..

si pones tu navegador

tudirecion/un_archivo_que_este_este_la_supuesta_carperta_que_esperas_entre_apache

tambien puede esar pasando que una configuracion en 000-.defaul este interfiriendo
puede probando desativanal 000-default

no se me courre nada mas...

bytes..
  
Puedes identificar cuál de los problemas que te dice pizzakiller es el que te pasa consultando el log de error de Apache (/var/log/apache2/error.log).
A mí siempre me pasa que no he escrito correctamente el "DocumentRoot", en ese caso en el log me aparece "File does not exist:"

Si no te apareciera nada en los logs, yo añadiría unas líneas:

ErrorLog /var/log/apache2/error.log
LogLevel info

a la configuración del VirtualHost si no las tiene, y entonces un /etc/init.d/apache2 reload . Imagino que en Ubuntu será igual ...


Saludos,
Marc ///
Hola a todos, muchas gracias a todos, el ultimo error era q en mis archivos de virtual host habia definido logs de acceso y errores para cada uno en ubicaciones diferentes y ahi habia cometido un error ortografico, los errores anteriores era el orden en como leia apache los archivos de virtualhost, yo tenia
NameVirtualHost *:80
en un archivo q levantaba en segundo orden debido al nombre del archivo.

Aclaro q el mensaje:
[warn] NameVirtualHost *:80 has no VirtualHosts ... waiting
> [Wed Jul 01 11:42:38 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
continua saliendo pero funciona perfectamente.

Reply to: