[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(Lenny) Plataforma no soportada



No se si a ustedes les pasa, pero tras actualizar lenny, cuando pretendía hacer una operación de configuración, por ejemplo "Ajustar fecha y hora", configurar red con networkmanager... Aparecía un diálogo de advertencia profesando "plataforma no soportada".
El error viene de que en /etc/debian_version aparece 5.0.1 y el paquete system-tools-backends-2.0, no la reconoce como una plataforma conocida.
Posibles soluciones....
Irse a /usr/share/system-tools-backends-2.0/scripts/Utils/Platform.pm
y añadir una entrada para la 5.0.1
 "debian-5.0.1"      => [ "Debian GNU/Linux", "5.0.1", "Lenny" ],
ésta quizás no sea una buena solución, aunque aparece el diálogo de plataforma no soportada, eliges la nueva entrada y ya deja de salir para siempre, quizás si volviese a cambiar /etc/debian_version por algo como 5.0.2, volvería a salir la advertencia.
Quizás una solución más limpia sería añadir en /etc/debian_version una línea tal que así:
Lenny
Y ya va para adelante la cosa.


Reply to: