[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problema con Aptitude: python-gobject, etc...



On Tue, Jan 29, 2008 at 09:08:44AM +0100, Randy wrote:
> Randy escribió:
> > Hola listeros;
> >
> > Al actualizar el sistema me encuentro con errores en los siguientes
> > paquetes:
> >
> > [ lista de paquetes ]
> >
> > Si lo veis conveniente os pego lo que me arroja aptitude, aunque es algo
> > extenso.
> >
> >   
> Bueno, como en este hilo no entra nadie pego lo que me dice Aptitude por
> si acaso alguien lo leyera :)

Gracias. Es difícil saber qué pasa si no nos dices qué pasa. ;)
 
>     AuruM:/home/randy# aptitude upgrade
>     [ ... ]
>     ¿Quiere continuar? [Y/n/?]
>     Escribiendo información de estado extendido... Hecho
>     (Leyendo la base de datos ...
>     228809 ficheros y directorios instalados actualmente.)
>     Preparando para reemplazar python-glade2 2.12.0-2 (usando
>     .../python-glade2_2.12.1-1_i386.deb) ...
>     Traceback (most recent call last):
>       File "/usr/sbin/update-python-modules", line 348, in ?
>         post_change_stuff(py)
>       File "/usr/sbin/update-python-modules", line 224, in post_change_stuff
>         file(initfile,"w").close()
>     IOError: [Errno 2] No such file or directory:
>     '/var/lib/python-support/python2.4/bootconfig/__init__.py'
>     dpkg: aviso - script de `pre-removal' antiguo devolvió código de error 1

Básicamente, el proceso de actualización cree que necesita eliminar
pedazos que se quedaron de un módulo 'bootconfig'. Pero al tratar de
eliminarlos, resulta que no están y falla con ese error.

Es decir, lo que pasa es que algo está confundiendo al sistema
diciendo en un lado que ese módulo existió y que ya no está, y en otro
que nunca existió, o que sí pero se eliminó bien.

Ahora bien, por más que busco, no encuentro en ningún lado un paquete
que contenga esos archivos. ¿Instalaste paquetes de algún depósito no
oficial? (Por cierto, ¿que versión estás usando?)

Manda por favor la salida de los siguientes 3 comandos:

ls /var/lib/python-support/python2.4
ls /usr/share/python-support/
dpkg -S /usr/share/python-support/bootconfig

A ver si alguno de ellos ayuda.

Attachment: signature.asc
Description: Digital signature


Reply to: