[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Consulta con synaptic/aptitude



2006/7/23, Mariano Alesandro <malesandro@gmail.com>:
2006/7/22, Aritz Beraza Garayalde [Rei] <aritz.beraza@gmail.com>:
> El Sábado, 22 de Julio de 2006 22:03, Mariano Alesandro escribió:
> > 2006/7/22, Damian Fossi <damianfossi@gmail.com>:
> > > On 7/22/06, Mariano Alesandro <malesandro@gmail.com> wrote:
> > > > Hola a todos!!!
> > > > Quería instalar el paquete mp3kult usando synaptic, pero me decía
> > > > que para hacerlo tenía que desinstalarme kde, entre otras cosas. Uso
> > > > kde, pero más allá de eso, no lo quiero sacar. Entonces traté de
> > > > hacerlo desde línea de comando haciendo aptitude install mp3kult, y
> > > > en la catarata de cosas que me tira, dice:
> > >
> > > zaMbomba!!!!!
> > >
> > > ¿Puedes mostrar tus repositorios?
> > >
> > > # cat /etc/apt/sources.list
> > >
> > > Saludos,
> > >
> > > --
> > > Damian D. Fossi Salas
> > > Debian Sarge, jugando con Etch ;-)
> > > Ubuntu Dapper Drake - AMD64
> > > Ulanix Beta 3
> > > FreeBSD 6.1
> > > Linux User: 188464
> > > Jabber ID: damianfossi en jabberes.org
> > > www.damianfossi.com
> >
> > Hola de nuevo, acá va el resultado del cat:
> > # deb file:///cdrom/ sarge main
> >
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-6
> > (20050607)]/ unstable contrib main
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-5
> > (20050607)]/ unstable contrib main
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-4
> > (20050607)]/ unstable contrib main
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-3
> > (20050607)]/ unstable contrib main
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-2
> > (20050607)]/ unstable contrib main
> > # deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-1
> > (20050607)]/ unstable contrib main
> >
>
> Si vas a usar internet para actualizaciones, y nuevos paquetes, estas
> lineas sobran (las de arriba)
>
> > deb http://security.debian.org/ stable/updates main contrib
> >
> > deb http://ftp2.de.debian.org/pub/debian/ stable main contrib
> >
>
> En los dos casos de arriba si pones non-free al final de la linea accederas
> a más paquetes, algunos interesantes.
>
> > deb http://ftp2.de.debian.org/pub/debian-non-US/ stable/non-US main
> > contrib
> >
>
> ¿Sigue existiendo non-US?
>
> >
> > deb http://ftp2.de.debian.org/pub/debian/ unstable main contrib
> >
>
> Unstable? Has instalado algo de unstable en stable? yo borraría esta linea,
> han cambiado demasiadas cosas entre ambas distribuciones como para ir
> trasteando. Seguramente es mucho mejor pasarse a testing que no mezclar
> stable y unstable.
>
> > deb http://www.planet-moll.de/debian/ sarge main
>
> Este de aquí arriba fuera
>
> > deb http://ftp.de.debian.org/debian/ stable non-free main
> >
>
> Anda, si el non-free lo tenías aquí!
>
> > deb http://idefix.eup.uva.es/debian-marillat/ sarge main
> >
> > Lo dejé así como salió, con los espacios entre líneas, no sé si
> > significará algo....
>
> No.
>
> Un par de consejos. Intenta usar mirros próximos a ti geográficamente,
> sobrecargarás menos la red. Ahora mismo estás usando mirrors en alemania,
> en españa hay varios mirrors (el es.debian.org, el de rediris, y varias
> universidades tienen mirrors parciales (solo la arquitectura x86).
>
> Sanea el sources list, un apt-get update, apt-get upgrade. Te quedarán
> seguramente muchos paquetes retenidos, y esperemos que ninguno roto. El
> tema de paquetes rotos se suele arreglar con un apt-get -f install o
> eliminandolo a mano y reinstalando. Los paquetes retenidos se arreglan
> instalándolos de nuevo.
>
> Saludos
> Aritz Beraza [Rei]
> --
> Aritz Beraza Garayalde [Rei]   [http://www.ayanami.es]
> - No enviarás correos en HTML a La Lista.
> - No harás top-posting, responderás siempre debajo del mail original.
> - No harás Fwd, a La Lista, siempre reply.
>
>
>

Bueno, acá sigo arreglando (intentando arreglar) el tema de los
paquetes rotos, repositorios, etc etc etc.
Hice un apt-get update && apt-get upgrade  y me bajó y configuró
varias cosas, pero al final, termina así:

Configurando libxmu-dev (4.3.0.dfsg.1-14sarge1) ...
Configurando libxrandr-dev (4.3.0.dfsg.1-14sarge1) ...
Configurando xlibmesa-gl-dev (4.3.0.dfsg.1-14sarge1) ...
Configurando xlibmesa-glu-dev (4.3.0.dfsg.1-14sarge1) ...
Se encontraron errores al procesar:
 kernel-image-2.4.27-2-386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y corta, quedo en # nuevamente......
De cualquier manera, voy a tratar de limpiar los paquetes rotos con
apt-get -f install y voy a hacer el upgrade y update de nuevo.
DEspués sigo comentando qué pasó.
Saludos y gracias a todos los que me ayudan!!
Mariano


Una cosa más....cuando hago apt-get -f install, me tira lo siguiente:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 0B de archivos.
Se utilizarán 0B de espacio de disco adicional después de desempaquetar.
Configurando kernel-image-2.4.27-2-386 (2.4.27-10sarge1) ...
/bin/bash: error while loading shared libraries: libdl.so.2: cannot
open shared object file: No such file or directory
Failed to create initrd image.
dpkg: error al procesar kernel-image-2.4.27-2-386 (--configure):
el subproceso post-installation script devolvió el código de salida de error 9
Se encontraron errores al procesar:
kernel-image-2.4.27-2-386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Es una ampliación del error que antes dije, pero acá hay más info. Alguna idea?
Mariano

Reply to: