[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problemas con usuario en Particion /home



El Jueves, 6 de Abril de 2006 23:13, Luis Vega escribió:
> El día 6/04/06, Ricardo Frydman Eureka! <ricardoeureka@gmail.com> 
escribió:
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> >
> > Luis Vega wrote:
> > > Hola amigos d ela lista, hace rato que no escribia.
> >
> > Pues entonces dejame recordarte que aqui debes evitar el HTML...
>
> Hola,  siempre he enviado mensajes en  texto plano, no se a que te
> refieres.
>

Revisa la configuración de tu cliente, te está jugando una mala pasada:
<br>
Hola,&nbsp; siempre he enviado mensajes en&nbsp; texto plano, no se a que 
te refieres. <br>
</div><br><blockquote class="gmail_quote" style="border-left: 1px solid 
rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 
1ex;">&gt;<br>&gt; Bueno, el problema que tengo es el 
sgte.<br>&gt;<br>&gt; Tengo un hdd de 40 gb con tres particiones. /, /home 
y /swap, este disco


> > > Bueno, el problema que tengo es el sgte.
> > >
> > > Tengo un hdd de 40 gb con tres particiones. /, /home y /swap, este
> > > disco lo he trasladado a diferentes PCs, en donde agrego al usuario
> > > correspondiente a mi sistema, por ejemplo si mi usuario se llama
> > > lvega, en el PC donde pongo el disco agrego al usuario lvega
> > > indicando q su home estara en mi disco en la particion /home. Lo
> > > anterior ha funcionado muy bien en varios PCs con Debian Sarge.
> > >
> > > Ayer, decidi hacerle una nueva instalacion a la raiz de mi disco, a
> > > traves de netinstall, lo primero que hice fue instalar el sistema
> > > base,
> >
> > Puedo preguntar con que objeto?
>
> Resintale el sistema porque necesito usar debian  etch, mas actualizado,
> sin importar que sea testing y por razones de compatibilidad de hardware
> mas que nada, y tambien para probar que tal anda en mi PC.
>
> > una vez hecho esto cambie los repositorios a testing para instalar
> > etch
> >
> > > desde la base y luego instalar las X. Todo quedo muy bien, incluso
> > > el monitor LCD toma a 2048x1024.
> > >
> > > El problema esta en que el usuario lvega, de la particion home no
> > > puede iniciar una sesion X con gnome. El es el siguiente:
> > >
> > > [...]
> > >
> > > /etc/gdm/PreSession/Default: Registering your session with wtmp and
> > > utmp /etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a
> > > -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h
> > > "" -l ":0" "lvega"
> > > /etc/gdm/Xsession: Beginning session setup...
> > > SESSION_MANAGER=local/fodsite:/tmp/.ICE-unix/9420
> > > The application 'gnome-session' lost its connection to the display
> > > :0.0; most likely the X server was shut down or you killed/destroyed
> > > the application.
> > >
> > > [...]
> > >
> > > Tambien, al iniciar la sesion con gnome, me aparece un error de
> > > permisos, dice que el usuario lvega no tiene los permisos
> > > suficientes para iniciar la sesion, asi que como root hice:
> > >
> > > # chown lvega:lvega -R /home/lvega/
> > >
> > > Con esto, al poner user y pass al momento de hacer login, se queda
> > > parado en la carga de Metacity, y no inicia la sesion.
> > >
> > > He agregado un nuevo usuario en la misma particion home y toda anda
> > > muy bien, no he tenido problemas con eso, es solo con el usuario
> > > lvega, que como dije antes lo he mantenido por varios meses estable.
> >
> > Fijate si el UID y/o GID  coinciden.
>
> Coinciden muy bien.
>
> Como dijo Angel,  anteriormente probe con:
>
>  # chown -R lvega:lvega /home/lvega/
>
> pero aun asi se queda pegado cuando hace la carga de Metacity.
>
> otro dato, es que al iniciar sesion solo en modo texto, lo hace
> correctamente, es decir, el problema va por el uso de las X para ese
> usuario en comun.
>
> saludos.
>
> > > espero que me puedan ayudar.

Posiblemente tengas una configuración de sesión erronea (de ahí que se te 
quede "colgado" al arrancar gnome. Me ha pasado alguna vez al actualizar 
una versión de gnome (de 2.6 a 2.10 por ejemplo). La solución drástica es 
borrar el directorio con la configuración de gnome. Perderás la 
configuración de gnome (temas de escritorio, iconos, asociaciones de 
archivos, etcetc. Por si acaso, mueve los .xsession, .xinit y todos los 
archivos relacionados con el inicio de sesión a otra parte para ver si 
tienen algo de culpa. Si no, mueve los directorios .gnome* a alguna otra 
parte.

Salduso
Aritz Beraza [Rei]
-- 
Aritz Beraza Garayalde [Rei]   [http://www.ayanami.es] 
- No enviarás correos en HTML a La Lista.
- No harás top-posting, responderás siempre debajo del mail original.
- No harás Fwd, a La Lista, siempre reply.

Attachment: pgp9iL5vjkcgv.pgp
Description: PGP signature


Reply to: