[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error de dma a instalar un nuevo Kernel - Ayuda por favor



El Sábado, 1 de Abril de 2006 16:39, Santiago Yegros escribió:
> Bueno, tengo un problema al instalar una version nueva del kernel en
> mi Debian Sarge. La cosa es asi: tengo instalado el Debian con el
> kernel por default, el 2.4.x, este kernel no tiene soporte para discos
> SATA, memoria flash(pendrive), PCIexpress, y otras cosas. Bueno,
> entonces quise instalar un kernel mas nuevo, el 2.6.8, bueno el los
> CD's de debian encontre el 2.6 para todas las plataformas entre ellas
> 3 para amd64(mi plataforma), instale los packetes todo bien, y al
> tratar de iniciar con el nuevo kernel me sale este error:
>

En un amd64 puedes correr tanto debian ix86 como debian amd64, asumiré que 
usas debian ix86. En este caso y dado que los kernels de debian amd64 
tienen soporte 32 bits no hay problemas en usarlos en debian ix86. Si es 
al revés si que lo hay. Los kernels de debian ix86 aunque funcionan 
perfectamente no tienen soporte para 64 bits y por tanto no pueden 
ejecutar los programas de debian amd64.

> ide: Assuming 33 Mhz system bus speed fot PIO modes, override with
> idebus=xx NFORCE-CK804 : IDE controller at PCI slot 0000:00:06.0
> NFORCE-CK804 : chipset revision 162
> NFORCE-CK804 : not 100% native mode: will prove irqs later
> NFORCE-CK804 : BIOS didn't set cable bits correctry. Enabling Workaround
> NFORCE-CK804 : 0000:00:06.0 (rev a2) UDMA133 controller
>      ide0 : BM-DMA at 0x1000-0x1007, BIOS settings : hda:DMA, hdb:DMA
> NFORCE-CK804 : simplex device : DMA disable (BIOS)
> hda: ST380011A, ATA Disk drive
> ide0: at 0x1f0-0x177, 0x3f6 or irq 14
> hdc: HL-SL-STDVDRRW GWA-4161B, ATAPI CD/DVD-ROM drive
> ide0: at 0x1f0-0x177, 0x376 or irq 15
> hda: max request size: 512KiB
> hda: 156301488 sectors (80026 MB) w/2048 KiB Cache, CHS=16383/255/63,
> UDMA(100) hda: cache flushes supportes
> hda: <4>
> hda: dma_expiry : dma status ==0xff
> hda: dma_expiry : dma status ==0xff
> hda: dma_expiry : dma status ==0xff
> .......................................................y
> sigue.............................
>

el status 0xff creo que significa busy (ocupado). ¿Se te queda bloqueado el 
equipo en este caso? He leido de gente que ha solucionado problemas 
similares arancando con las opciones noapic y acpi=off Pero no funciona en 
todos los casos... 

>  Obviamente es un error de DMA, ya entre en mi BIOS 4548541563 veces y
> el DMA esta habilitado, proBe cambiando todos los cable de hd y
> tampoco no pasaba nada.
>

Si lo de arriba no funciona, desactiva el dma desde la bios y prueba a 
arrancar.

> Bueno, busque informacion por ahi, por foros y demas, y me recomndaron
> recompilar el kernel en mi maquina, entonces, baje el kernel mas
> nuevo, recompile todo bien, instale el kernel, y que paso, el mismo
> error de mier....
>

Los kernels anteriores al 2.6.12 tienen _muchos_ problemas con los amd64 
(por lo menos si están compilados para esta arquitectura). Lo de 
compilarse uno mismo su kernel tiene sus problemas, especialmente que te 
dejas cosas importantes. Instalate el paquete 
linux-image-2.6.16-rc5-amd64-k8
de debian amd64 (sid), a ver que tal tira.

Si usabas un kernel 2.4 es por que estás en la rama estable... Antes de 
hacer esto te recomiendo que actualices a testing (etch). 

> OBS:
> Lo raro es que puedo instalar el UBUNTU, UBUNTU x64, KNOPPIX sin
> problema. Tambien probe ponerle los kernel's de los cd's de debian en el
>  ubuntu y me sale el mismo error.}
> Tambien hoy acabo de Probar el Nuevo Fedora Core 5, y insertar el DVD
> ya me dale el mismo error
>

Como ya he dicho, los kernels 2.6.x inferiores al 2.6.12 no tienen un buen 
soporte para hardware amd64. En concreto creo que el soporte para nforce4 
se añadió en el 2.6.11. Prueba a usar un kernel oficial de debian 2.6.15 o 
2.6.16 (en los repositorios de unstable tienes estas versiones).

Fedora.... Prefiero no comentar nada, por que no tengo nada bueno que decir 
de esta distribución.

> MI PC: es la sgte, si le sirve de algo la informacion:
> Proc AMD athlon 64 2800+
> MB Asus K8N4- Deluxe (chipset nvidia NFORCE 4)
> hd´s 1- SATA 80gb (Guindows)
>       2- Ide 80gb (linux, etc)
> RAM 512mb
> Vga ATI X300 128Mb PCIexprees
> Grabador DVD

Si vas a usar software 64 bits te recomiendo que le metas 512 megas de ram 
extras...

Saludos
Aritz Beraza [Rei]
-- 
Aritz Beraza Garayalde [Rei]   [http://www.ayanami.es] 
- No enviarás correos en HTML a La Lista.
- No harás top-posting, responderás siempre debajo del mail original.
- No harás Fwd, a La Lista, siempre reply.

Attachment: pgpldLEMVmD8e.pgp
Description: PGP signature


Reply to: