[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Apache2 se cuelga con php4 tras último upgrade



Hola,

Escribo en esta lista porque tampoco sé muy bien donde acudir ya que
desconozco la raiz del problema. Tengo un servidor apache con php
funcionando sin problemas. Funcionando... hasta el día de ayer ya que
tras el último upgrade el servidor ha dejado de funcionar. No estoy
seguro de si se trata de un problema de configuración, o de un error de
librería (como parece ser) ya que no veo en la www nada al respecto.

Los paquetes actualizados son los siguientes:

ii  apache2-common                2.0.50-9
ii  apache2-mpm-prefork           2.0.50-9
ii  libapache2-mod-php4           4.3.8-5

El problema parece estar en php ya que si inicio apache2 sin el módulo
de php4 el servidor funciona sin problemas (pero sin php, obviamente)

No tengo experiencia en el manejo de gdb desde la consola, pero los
resultados indican que la librería libphp4.so provoca una violación de
segmento que hace que el servidor entero caiga en cuanto se trate de
visualizar cualquier página, sea o no php.

(gdb) run -X
Starting program: /usr/sbin/apache2 -X
[New Thread 1079486752 (LWP 17700)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1079486752 (LWP 17700)]
0x406d8957 in execute () from /usr/lib/apache2/modules/libphp4.so

Dicha librería forma parte del paquete libapache2-mod-php4 por lo que he
probado a instalar una versión anterior pero obtengo el mismo fallo, así
que me ha hecho dudar de si es problema de php, es problema de
configuración o de apache2. 

Si alguno tiene alguna idea de cual puede ser el problema o necesita más
datos rogaría que lo comentara en este hilo.

Saludos, JKD

P.D.: Linux debian 2.6.8.1 #1 SMP Sun Aug 15 13:13:45 CEST 2004 i686 GNU/Linux



Reply to: