[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: El dpkg de Slink peta



Jordi Roman Mejias wrote:
> ....
> >
> > Prueba con los paquetes que daban segfault al instalarlo con
> >
> > LC_ALL=C dpkg -i paquete...
> 
> Estabas en lo cierto, cambiando la variable LC_ALL ha funcionado a la
> primera.

estupendo, vamos acotando el problema

> 
> Pero hay una cosa mas como no funcionaba el dpkg 1.4.0.31 instale la
> version de hamm (la 1.4.0.23.2) y probe a instalar el wmaker0_20.... y
> tambien fallaba

Yo hice lo mismo por si era un problema de la versión del dpkg y tuve el
mismo resultado, fallaba 

> 
> Ahora he probado a instalar el nuevo wmaker con la version de hamm del
> dpkg y ha funcionado correctatmente.
> 

¿con el LC_ALL=C primero o sin él?

> 
>  Muchimimas gracias por tu ayuda

De nada.

Para información general he rebuscado en la lista de bugs de dpkg y he
en contrado el siguiente:
-----------------------------------------------------------------
Debian bug report logs - #27587
dpkg: segfaults on errors when LC_ALL or LANG are set
-----------------------------------------------------------------
From: ujr@physik.phy.tu-dresden.de (Ulf Jaenicke-Roessler) --- El
original

this is just another dpkg effect when Locales are used:

ujr [~] 500> echo $LANG
de_DE
ujr [~] 501> echo $LC_ALL
de_DE
ujr [~] 502> mkdir t
ujr [~] 503> cd t
ujr [~/t] 504> dpkg --info test.deb
Speicherzugriffsfehler                  <-- ie. Segmentation Fault
ujr [~/t] 505> unset LANG LC_ALL
ujr [~/t] 506> dpkg --info test.deb
dpkg-deb: failed to read archive `test.deb': No such file or directory

I get the same error, when I want to install a package with 'dpkg -i'
while
 my /usr partition is mounted read-only.


---------------------------------------------------------------------------
From: Raphael Hertzog <rhertzog@hrnet.fr>          --- La primera
respuesta

dpkg can core dump when installing a package and using a locale
like fr_FR.

If you want to track down the problem, you can test it by setting
LC_ALL=fr_FR et running dpkg -i xbase_3.3.2.3a-7.deb (having an
oldest set of X packages installed). I can send you the core if you
want... but it takes about 9MB.

The bug is only marked 'normal', but it should be important i think.
---------------------------------------------------------------------------

es decir, parece que el problema es conocido y ya está comunicado, sólo
que con una importancia que a mí me parece pequeña. He mandado lo de que
parece que con LC_ALL=C sí funciona y a ver que tal.

Saludos,


-- 
=====================================================================
Agustín Martín Domingo, Dpto. de Física, ETS Arquitectura Madrid, 
(U. Politécnica de Madrid)  tel: +34 91-336-6536, Fax: +34 91-336-6554, 
email:agmartin@aq.upm.es, http://corbu.aq.upm.es/~agmartin/welcome.html


Reply to: