[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Res: Re: Squid transparente + squidGuard



então quando ligo o computador, ou a qualquer hora que eu rodar o comando tail /var/log/squid3/squidGuard.log
para verificar o final do arquivo, vejo que ele carregou e parou na hora em que foi executado este comando a pela última vez.

segue resultado de um ps ax | grep squid
 1920 ?        Ss     0:00 /usr/sbin/squid3 -YC -f /etc/squid3/squid.conf
 1922 ?        S      0:00 (squid) -YC -f /etc/squid3/squid.conf
 1934 ?        S      0:00 (squidGuard)
 1935 ?        S      0:00 (squidGuard)
 1936 ?        S      0:00 (squidGuard)
 1937 ?        S      0:00 (squidGuard)
 1939 ?        S      0:00 (squidGuard)
 1941 ?        S      0:00 (squidGuard)
 1942 ?        S      0:00 (squidGuard)
 1943 ?        S      0:00 (squidGuard)
12482 pts/0    R+     0:00 grep squid

aparentemente ele está rodando como serviço mas ao rodar o comando para ver o log, ele está parado, não aceita requisições. que seria algo similar a isto.

2012-03-13 20:39:12 [4313] squidGuard 1.4.0 started (1208175362.060)
2012-03-13 20:39:12 [4313] squidGuard ready for requests (1208175362.105)

e não faz bloqueio algum dos domínios que consta na lista, acessa normal.

não sei o que posso ter feito de errado, já passei olhando o tutorial do morimoto, mas aparentemente está correto.



On 15-03-2012 21:25, jmhenrique@yahoo.com.br wrote:
Você inicia o squidguard com squidguard -c all ?!?!?
Enviado pelo meu aparelho BlackBerry®

From: Ricardo Esdra <riesdra@zoho.com>
Date: Thu, 15 Mar 2012 19:56:46 -0300
Subject: Re: Squid transparente + squidGuard

testei aqui, o comando ficou rodando mais 20 minutos e não liberou a linha de comando,
então matei a execução com "ctrl C", não fez diferença nenhuma continua parando logo
que inicia o serviço com o comando squidGuard -C all.





On 15-03-2012 17:43, Fagner Patricio wrote:
Depois desses comandos:

chown -R proxy:proxy /var/lib/squidguard/db/*
find /var/lib/squidguard/db -type f | xargs chmod 644
find /var/lib/squidguard/db -type d | xargs chmod 755

Execute esse assim:

su - proxy -c '/usr/bin/squidGuard -C all'

Veja se resolve!

Em 15 de março de 2012 10:39, riesdra <riesdra@zoho.com> escreveu:
rodei estes comandos
chown -R proxy:proxy /var/lib/squidguard/db/*
find /var/lib/squidguard/db -type f | xargs chmod 644
find /var/lib/squidguard/db -type d | xargs chmod 755

segui o tutorial do morimoto




#############################

#      Ricardo Esdra        #
#                           #
#   linux user n° 446011    #
#############################


---- On Thu, 15 Mar 2012 09:51:19 -0300 Gabriel Ricardo<gricardo87@gmail.com> wrote ----

os db tão com permissoes de leitura??

Atenciosamente,
Gabriel Ricardo.



Em 15 de março de 2012 09:02, riesdra <riesdra@zoho.com> escreveu:
resolvi testar aqui em uma máquina virtual que tenho do debian wheezy, e dá o mesmo
problema o squidGuard para logo que inicia.





#############################
#      Ricardo Esdra        #
#                           #
#   linux user n° 446011    #
#############################


---- On Wed, 14 Mar 2012 11:10:00 -0300 riesdra <riesdra@zoho.com> wrote ----

no squid.conf eu acrescentei a linha 
redirect_program /usr/bin/squidGuard
e assim também
redirect_program /usr/bin/squidGuard
redirect_children 8
redirector_bypass on

já testei dois jeitos, elas ficam antes das regras, onde permite ou nega os acessos pelo squid.

#############################
#      Ricardo Esdra        #

 #                           #
#   linux user n° 446011    #
#############################


---- On Wed, 14 Mar 2012 09:15:57 -0300 Gabriel Ricardo <gricardo87@gmail.com> wrote ----

correto, e você ta chamando ele pelo squid? qual linha?

Atenciosamente,
Gabriel Ricardo.



Em 14 de março de 2012 08:10, riesdra <riesdra@zoho.com> escreveu:

eu descompactei a lista de arquivo Shalla's blacklist, depois configurei um squidGuard.conf básico
conforme abaixo;

dbhome /var/lib/squidguard/db/BL

logdir /var/log/squid3

dest porn {
domainlist porn/domains
urllist porn/urls
}

dest socialnet {
domainlist socialnet/domains
urllist socialnet/urls
}

acl {
default {
pass !porn !socialnet all
redirect http://www.site.com.br

não cheguei a mudar nada nos arquivos de blacklist


o que acho estranho que ao rodar os comandos
squidGuard -C all           e depois
tail /var/log/squid3/squidGuard.log

ai ele mostra que quando executei o primeiro ele iniciou mas logo em seguida parou o serviço,
conforme passei na mensagem original, não estou entendo o por que ele inicia e para logo em seguida.






---- On Wed, 14 Mar 2012 07:36:29 -0300 Gabriel Ricardo <gricardo87@gmail.com> wrote ----

você fez o update dos db?

Atenciosamente,
Gabriel Ricardo.



Em 13 de março de 2012 20:52, Ricardo Esdra <riesdra@zoho.com> escreveu:
Boa noite a todos,

tenho um squid transparente em minha máquina com SquidGuard, mas ao rodar o comando
tail /var/log/squid3/squidGuard.log, recebo o resultado abaixo;

2012-03-13 20:37:35 [4297] squidGuard 1.4 started (1331681844.879)
2012-03-13 20:37:35 [4297] db update done
2012-03-13 20:37:35 [4297] squidGuard stopped (1331681855.025)
2012-03-13 20:39:12 [4313] squidGuard 1.4 started (1331681942.305)
2012-03-13 20:39:12 [4313] db update done
2012-03-13 20:39:12 [4313] squidGuard stopped (1331681952.443)

o que na minha opinião esta parado, pois pele que vi ele teria que ficar com algo similar a isto;
2012-03-13 20:39:12 [4313] squidGuard 1.4.0 started (1208175362.060)
2012-03-13 20:39:12 [4313] squidGuard ready for requests (1208175362.105)


alguém sabe me ajudar a resolver isto, pois gostaria de fazer o bloqueio de domínios pelo squidgaurd.

desde já agradeço a todos.

--
##############################################
#              Ricardo Esdra                 #
#                                            #
#          linux user n° 446011              #
##############################################



--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/4F5FDDC8.1000205@zoho.com" target="_blank">4F5FDDC8.1000205@zoho.com











--
Fagner Patrício
João Pessoa - PB
Brasil


-- 
##############################################
#              Ricardo Esdra                 #
#                                            #
#          linux user n° 446011              #
##############################################


-- 
##############################################
#              Ricardo Esdra                 #
#                                            #
#          linux user n° 446011              #
##############################################

Reply to: