[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub - unaligned pointer - Inicializador não carrega



Flamarion,

Valeu pelas dicas, apesar de no fim eu não ter conseguido resolver meu problema com nenhuma delas.. =)

O que funcionou para mim foi usar o Unetbootin (http://unetbootin.sourceforge.net/) para instalar em um pendrive o SuperGrubDisk (http://www.supergrubdisk.org/), que por sua vez faz algum tipo de magia negra e consegue encontrar e carregar o grub que está perdido no hd, que então carrega o sistema.

Por alguma razão o hd principal estava indicado como hd(0,0), então tive que editar a entrada para hd(1,0) e só então consegui de fato iniciar o sistema.

Outra alternativa que pensei foi usar o init para mudar o runlevel para 5 enquanto estivesse acessado o sistema com um cd de resgate, mas não cheguei a testar essa solução.

O bug ainda persiste e o mantenedor do pacote não tem mais respondido meus emails, mas pelo menos por enquanto eu estou conseguindo usar meu sistema.

Abraços e valeu a ajuda!

André Nunes Batista
Blog: http://tagesuhu.wordpress.com/
PGP Public Key: 0x7b0590cb6722cf80


2010/6/19 Flamarion Jorge <flamarilinux@yahoo.com.br>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 19-06-2010 19:09, André Nunes wrote:
> Ola,
>
> Depois da penúltima atualização do grub-pc no debian sid meu grub não
> carrega mais. Tudo o que aparece é:
>
> Unaligned pointer 0x4c191bea - press any key
>
> Pressionando uma tecla qualquer ele então diz:
>
> No operation system found
>
> Esse bug já foi relatado por outros aqui:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=586143
>
> Mas a solução de usar o grub-install não funciona para mim.
>
> Já abri novo bug report
> (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=586449), mas estou
> precisando recuperar meu sistema com urgência então gostaria de saber se
> alguém nesta lista pode me dar alguma idéia de como fazê-lo.


NÃO SEI SE VAI FUNCIONAR, mas pode tentar assim:

"Boota" com o cd no modo rescue.

update-grup2
grub-install /dev/sdx

Se não der certo, boota novamente em modo rescue e tenta:

dpkg-reconfigure grub-pc e reconfigura o grub2.

Se não rolar, tenta editar o /etc/default/grub (de acordo com a
documentação) e reinstalar.

Na pior das hipóteses instala o lilo via apt, boota seu sistema,
reinstala o grub e ve se o problema persiste...

Como eu disse no início não sei se vai funcionar, são coisas que eu
tentaria no modo de recuperação.

No mais pode usar a criativiade, dar o boot no sistema você consegue sem
precisar do grub, isso eu tenho certeza.

E agora depois de escrever isso tudo eu li seu bug e vi que tentou
várias das coisas que eu escrevi hehehhe, mas para não perder o email
por completo... dá um confere no  /boot/grub/device.map e ve se está
tudo de acordo.

Quando atualizei meu sid houve uma atualização que dizia respeito a
identificação dos dispositivos e que modificaram meu fstab e meu
device.map (eu acho) e que me deu um pouco de dor de cabeça também.

O que eu fiz foi acertar o device.map, update-grub2 e grub-install
/dev/sdxxx

boa sorte

- --
Flamarion Jorge
OpenPGP Key: 6CA750E1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkwdW3UACgkQ0SDRnmynUOHvpgCgoufoWdc2NnO1XS9clinfW4CV
fnkAniVNWtKwqo68LB0bDzhxNhFXgPK1
=aYUu
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4C1D5B79.6050700@yahoo.com.br" target="_blank">http://lists.debian.org/4C1D5B79.6050700@yahoo.com.br



Reply to: