[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Não encontra o /dev/sda3 após Compilar kernel



2008/7/2 Max Dornelles <maxdornelles@hotmail.com>:

Srs.(a)
Boa tarde!

Estou com uma dificuldade que foge um pouco de meus conhecimentos. Após compilar um kernel novo( 2.6.25.8) para um servidor que estou instalando o sistema  na hora do boot não encontra a partição raiz...ele me dá uma mensagem que não conseguiu encontrar o dispositivo /dev/sda3. Tentei com diversas versões do kernel, inclusive na última somente disabilitei o item que gerencia a energia e o restante deixei default, pois achei que poderia ter sido algum item que tinha tirado, mesmo assim não foi!
Após o erro ele entra no prompt - /bin/sh

Estou enviando a saída do mount na versão do kernel instalada por default.

sr02:~# mount
/dev/sda3 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
/dev/sda5 on /dados type ext3 (rw)
/dev/sda6 on /usr type ext3 (rw)
/dev/sda7 on /var type ext3 (rw)

sr02:~# uname -r
2.6.18-6-amd64

Max, no caso deste kernel 2.6.18 a partição  está montada, não?
CR




--
CARLOS RIBEIRO
Linux-User: 183.572 Machine: 195.669
São Luís - Maranhão - Brasil
Reply to: