[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ap em bridge não pega nat do servidor



Obrigado pela ajuda de todos, mas não consegui resolver o problema, acredito que não seja problema de firewall

Aderbal Botelho escreveu:
 modprobe iptable_nat                                   #
 iptables -F
 iptables -F INPUT
 iptables -F OUTPUT
 iptables -F POSTROUTING -t nat
 iptables -F PREROUTING -t nat
 echo 1 > /proc/sys/net/ipv4/ip_forward
 iptables -P FORWARD ACCEPT
 iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu

# se o proxy for localhost
iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT
--to-port 3128

# se o proxy for outro servidor
# iptables -t nat -A PREROUTING -i eth3 -p tcp --dport 80 -j DNAT
--to-destination 127.0.0.1:3128

2008/6/16 Allison Vollmann <allisonvoll@yahoo.com.br>:
  
É o seguinte pessoal, tenho um servidor com duas interfaces de rede eth1
(rede interna) eth0 (internet), a interface eth1
está ligada em um hub onde tem x maquinas ligadas e um ap configurado em
modo ap mesmo com a mesma faixa de ips, nesse ap tem
outro ap fazendo brigde entre esse ap e um outro ap também configurado como
bridge, todos usando a mesma classe de ip.

ou seja:

Eth0-Servidor-Eth1-Hub-Ap-Ap2(bridge)-Ap3(bridge)-Rede Secundária

onde:
Eth0: 201.x.x.x (Internet)
Eth1: 192.168.2.1 (Rede Primária)
Ap: 192.168.2.100 (Rádio em modo AP)
Ap2: 192.168.2.110 (Rádio em modo bridge)
Ap3: 192.168.2.120 (Rádio em modo bridge)
Rede Secundária: 192.168.2.x (Rede Secundária)

NetMask: 255.255.255.0


Regras de NAT (Iptables)

iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain

iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD --in-interface eth1 -j ACCEPT

echo 1 > /proc/sys/net/ipv4/ip_forward


Agora o problema....

a rede secundária só consegue acessar a internet utilizando proxy
autenticado (squid), se pingar da Rede Secundária
para a internet não retorna resposta alguma, para o restante da rede está
respondendo normalmente. A rede primária consegue
pingar normalmente para a internet, e também consegue acessar a internet sem
o proxy, isso comprova que o nat está funcionando
corretamente, então porque não acontece o mesmo com a rede secundária?
preciso fazer roteamento no servidor mesmo usando a mesma faixa
de ips e o mesmo netmask? como deverá ser esse roteamento? se consigo pingar
da rede interna para rede secundária e vice-versa
teóricamente o roteamento entre elas está certo, não?

Valeu, isso está me dando dor de cabeça já há muito tempo.


--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org


    



  


Reply to: