[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problemas com apt-get install



Fernando Guimarães escreveu:
Pois é, nada ainda, ja havia tentado com -f , mas sem sucesso.
Gostei da dica do bash.... com certeza vai ajudar muito mesmo ;)
segue abaiso um print da tela:

guima:~# apt-get install bind9
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
  bind9: Depends: libisccc0 (= 1:9.2.4-1) but 1:9.3.1-2 is to be installed
E: Broken packages
guima:~# apt-get install -f
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
guima:~# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
guima:~#
Mesmo assim, grato pela ajuda!
[ ]'s Fernado  F. Guimarães

    ----- Original Message -----
    *From:* Daniel Lemos Gontijo <mailto:daniel.gontijo@mte.gov.br>
    *To:* Lista DebianBR <mailto:debian-user-portuguese@lists.debian.org>
    *Sent:* Thursday, February 09, 2006 12:06 PM
    *Subject:* Re: Problemas com apt-get install


    Bom dia Fernando,

    Geralmente é possível resolver problemas de dependência com o comando:

    *apt-get install -f*

    Já tentou isso? Ele (teoricamente) corrigirá os problemas de
    dependência.


    Obs:

    Aproveito para sugerir a ativação do "bash_completion"

    Basta inserir no final do ".bashrc" a linha: *source
    /etc/bash_completion*

    Desta forma, sempre que você digitar apt-get install e parte do
    nome do pacote, basta pressionar o TAB para que ele complete o
    nome, evitando erros e facilitando 1000x o uso do APT. (assim como
    ocorre nos comandos do shell)


    Abraços!





    Em Qui, 2006-02-09 às 11:56 -0200, Fernando Guimarães escreveu:
Opa pessoal, tudo bom??? realmente devo assumir que não domino ainda o sistema de gerenciamento de pacotes do debian. o kernel que uso é o 2.6.12.2-guima, compilado por eu mesmo. Apesar de ja ter lido algumas poucas documentações, bem como
    manuais do apt-get, não descobri como solucionar problemas de
pacotes que não podem ser instalados. Em meu souces.list tenho o seguinte:
    deb http://ftp.us.debian.org/debian/ stable main non-free contrib
    deb http://non-us.debian.org/debian-non-US stable/non-US main
    contrib non-free
    deb http://security.debian.org/ stable/updates main contrib non-free
    deb-src http://ftp.us.debian.org/debian/ stable main non-free contrib
    deb-src http://non-us.debian.org/debian-non-US stable/non-US main
    contrib non-free

    Ao meu entender, isso quer dizer que uso a versão stable do
    sarge. Ja fiz o apt-get update e dist-upgrade, e ambos
    funcionaram corretamente. Hoje surgiu uma necessidade, e com o
ela o meu problema: Preciso instalar o bind9 . fui lá e apt-get install bind9 ....e:

    The following packages have unmet dependencies:
      bind9: Depends: libisccc0 (= 1:9.2.4-1) but 1:9.3.1-2 is to be
    installed
E: Broken packages Como eu deveria comecar a tentar solucionar este problema, ou
    seja, qual seria a melhor coisa a se fazer nesta situação,
    desistalar o pacote libisccc0 e tentar colocar um mais
    novo/antigo e depois tentar colocar o bind,  desencanar de tentar
resolver e baixar um .tar.gz e compilá-lo na unha??? No meu caso tem de ser o BIND mais novo, pois vou usá-lo como DNS
    de AD respondendo a requisições SRV sendo que somente os binds
mais novos tem suporte. Se alguem tiver paciência em explicar agradeceria muito, ou mesmo
    de indicar alguma documentação sobre problemas com apt/dpkg pois
    diversas vezes que esbarrei em problemas como esse, parti pro
tar.gz e desencanei de tentar solucionar o problema. Atenciosamente, Fernando F. Guimarães!

Procure um repositório que tenha o pacote que você precisa e adicione a seu sources.list é só olhar em http://www.apt-get.org/ acho que isso resolve,
ou
baixe o pacote e instale com o dpkg -i XXXXXX



Reply to: