[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RES: Erro persiste... Kernel 2.6.8 - Ajuda por favor!!!! Unable to mount....



O kernel que eu vi funcionar até agora, foi o précompilado que veio com o Debian
Sarge... 2.6.7 ou seja, não posso avaliar o .config né ? Cara, to achando
esquisito demais isso, porque eu já compilei uma vez o kernel 2.6.8 no debian há
algumas semanas atras deu certo, mas em uma outra máquina com a mesma
configuração da minha.. Tenho certeza absoluta, que é vacilo de algum modulo ou
built-in dessas novas opções de chipset ou IDE que não coloquei, ou que coloquei
e não era para ter colocado...

:/ Alguem tem o 2.6.8 funcionando aí? com ext3 ? Poderia mandar a config para
dar uma avaliada ??

Obrigado,
Arthur


-----Mensagem original-----
De: Leonardo Lourenço Crespilho [mailto:lcrespilho@yahoo.com.br]
Enviada em: terça-feira, 21 de setembro de 2004 12:51
Para: Arthur Tupinambá; debian-user-portuguese
Cc: Fábio Daniotti Maschio
Assunto: Re: Erro persiste... Kernel 2.6.8 - Ajuda por favor!!!! Unable
to mount....


Arthur...  não sei o q vc pode fazer... Qual o seu kernel que funciona? Que
versão? Tenta comparar o .config do kernel antigo com o .config do kernel
novo. Coloca o .config do kernel antigo no /usr/src/linux/.config e
configura o kernel com "make oldconfig". Isso vai fazer com que somente as
novas opções do kernel 2.6.8 (que não existiam no seu kernel antigo) sejam
perguntadas. Daí vc configura as novas opções como módulo, built-in ou "not
configured".

Depois tenta compilar de duas formas. Com o initrd e sem o initrd.

Com initrd:
# make-dpkg --initrd --bzimage --revision=teste1.0 kernel_image
modules_image
Instala as imagens geradas no diretório /usr/src/_imagens_.deb
Inclua, no grub, a imagem initrd gerada.
Reinicia e testa.

Sem initrd:
# make-dpkg --bzimage --revision=teste1.0 kernel_image modules_image
Instala as imagens geradas no diretório /usr/src/_imagens_.deb
RETIRE, do grub, a entrada para a imagem initrd.
Reinicia e testa.


Se não funcionar, deve ser problema com o 2.6.8. Pra mim deu muito problema
também... e pelo que estou lendo nas listas de discussões, esse kernel tá
cheio de problema.

Estou curioso pra saber se funciona ou não. Nos mantenha informado. rsrs...
É que por enquanto estou sem máquina para fazer mais testes (VIU FÁBIO). Daí
não dá pra aprender mais (VIU FÁBIO...hehehe)

Abraços,
Leonardo Lourenço Crespilho
http://www.nbis.com.br



----- Original Message -----
From: "Arthur Tupinambá" <ahenrique@synchro.com.br>
To: "Yuri de Souza" <yurobs@yahoo.com.br>
Cc: <debian-user-portuguese@lists.debian.org>
Sent: Tuesday, September 21, 2004 12:22 PM
Subject: RES: Erro persiste... Kernel 2.6.8 - Ajuda por favor!!!! Unable to
mount....


> Yuri,
>
> O sistema do diretório raiz é ext3
>
> Obrigado,
> Arthur
>
> -----Mensagem original-----
> De: Yuri de Souza [mailto:yurobs@yahoo.com.br]
> Enviada em: terça-feira, 21 de setembro de 2004 12:12
> Para: debian-user-portuguese
> Assunto: Re: Erro persiste... Kernel 2.6.8 - Ajuda por favor!!!! Unable
> to mount....
>
>
> Arthur, me responda uma coisa:
>
> Qual o sistema de arquivos do seu diretório raiz?
>
> É Reiser Fs???
>
> Até
>
>
>  --- Arthur Tupinambá <ahenrique@synchro.com.br>
> escreveu:
> > Pessoal,
> >
> > Já deve ser a 50º vez que estou recompilando o
> > kernel sem sucesso...
> > Alguem pelo amor de Deus me de uma luz :/ Já li
> > quase todas as referências
> > indicadas no Google.... Mais não estou conseguindo!
> >
> > O erro:
> > devfs_mk_dir: Invalid argument <6>hda: hda1 hda2
> > hda3 hda4
> > kernel panic: VFS Unable to mount root fs on (3,2)
> >
> > Meu /boot/grub/menu.lst:
> > root(hd0,1)
> > kernel /boot/vmlinuz-2.8.1 root=/dev/hda2
> > initrd /boot/initrd-2.8.1
> > boot
> >
> > Sintaxes que eu utilizei
> > #make menuconfig #Configurei o kernel (EM ANEXO)
> > #make-kpkg --revision=teste1.0 kernel_image
> > #dpkg -i kernel-image2.6.8teste.1.0.deb
> > #mkintrd -o /boot/initrd-2.8.1
> > #vi /boot/grub/menu.lst (e coloquei a linha do
> > initrd no kernel novo)
> > #reboot :) (infelizmente sempre tive que voltar para
> > o kernel antigo... ARGH!!!)
> >
> > Meu hardware:
> > Placa Mãe MSI NEO 875p (chipset intel 875p)
> > HD Maxtor 80gb 7200rpm
> > Intel p4 2.4 HT
> >
> >
> > Em anexo tá o meu .config atual.... antes eu estava
> > usando o kernel baixado do
> > site kernel.org,
> > porém, agora estou usando o kernel-source baixado
> > site do Debian devido aos
> > patches....
> >
> > Obrigado pela ajuda !!
> > Abraços
> >
> > ----------------------------
> > Arthur Henrique S. Tupinambá
> >  ahenrique@synchro.com.br
> > ----------------------------
> > Synchro Sistemas de Informação
> >     www.synchro.com.br
> > ----------------------------
> > Fone   : +55 ( 11 ) 3758 - 0021 / R. 187
> > Fone   : +55 ( 11 ) 3758 - 0038
> > Fax     : +55 ( 11 ) 3758 - 3773
> > Mob    : +55 ( 11 ) 7718 - 5371
> > E-mail  : ahenrique@synchro.com.br
> > ----------------------------
> >
>
> > ATTACHMENT part 2 application/octet-stream
> name=.config
>
>
>
>
>
>
> _______________________________________________________
> Yahoo! Messenger 6.0 - jogos, emoticons sonoros e muita diversão. Instale
agora!
> http://br.download.yahoo.com/messenger/
>
>
> --
> To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
>
>
> --
> To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
>


--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: