[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Python e PyQT



Olá pessoal, 

   estou com um problema que ainda não consegui sequer uma referência de como 
resolver.

Trata-se da seguinte mensagem quando executo o python2.3

warning: Python C API version mismatch for module readline: This Python has 
API version 1012, module readline has version 1010

Eu não conheço nada de python, na verdade é exatamente isso que estava 
tentando fazer quando comecei a observar esse problema.

No meu sistema tem o python 2.1, 2.2 e o 2.3, isso devido a softwares que 
pedem esses sistemas ...  quando eu vou instalar

Mas o  python 2.1 e o 2.2 estão funcionando normalmente, inclusive tive de 
reconfiguar o sistema para entender o python default como o 2.2 para consegui 
usar programas que possuem chamadas em c no script, mas venho tentando 
consertar esse problema a algum tempo para usar o default o 2.3 (que é o 
default de fato).

Bem, já tentei

- dpkg-reconfigure python2.3 = > Só tive mensagens de erro e no final na 
mudou.
- reinstalar => Continuando o mesmo (mudou apenas as minhas configurações de 
links simbólicos, mas isso era de se esperar)
- remover e instalar => Não deu certo (Só me deu trabalho)
- instalar um software que depende-se do python2.3 corretamente instalado a 
partir do source, usando o auto-apt ( não deu certo, no final o sistema me 
comunicou que não podia prosseguir devido a essa configuração).
- procurar um arquivo de configuração do python (achei que lá podia ter uma 
dica, mas não consegui achar tal arquivo, e até desconfiei de que se acha-se 
podia nao ter muito o que fazer)

Uma coisa que me pareceu importante; a versão do GCC
O python está chamando o GCC 3.3.4
Mas eu tenho todos instalados no computador, desde GCC 2.x até o experimental 
GCC 3.5.1; fiquei pensando que o python2.3 não sabia lidar com chamadas em 
C/C++ mas creio que isso seja ignorância minha ==> Pelo menos baseado no que 
li a respeito de python.

É claro que para começar a aprender essa linguagem (algo que já devia ter 
feito a muito tempo) não faz diferença se estou com o 2.1 ou 2.3 se o script 
for apenas de python todos estão funcionando, mas seria legal resolver isso, 
até para instalar outros softwares.

Quanto ao PyQT, queria instalar um, para instalar outro software que deveria 
usar isso, eu tentei usar o source disponível no site do PyQT, mas ele 
reclama da ausência do SID, tudo bem, instalo ele mas não consegui resolver 
as dependências. Continua não sendo possível instalar o PyQT por nao 
conseguir resolver o modulo do Python e assim fico na mesma... acho que tem 
haver com mesmo problema mencionado acima

Agradeço a ajuda...
J. F. Mitre




Reply to: