[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB-Geräte werden bei mir immer im langsamen USB 1.1 Modus gefahren?!



Am Donnerstag, 1. Dezember 2011 schrieb Andreas Gottwald:
> Am 27.11.2011 20:10, schrieb Martin Steigerwald:
> > So oder so fehlen noch viel zu viele Infos:
> > 
> > - Was für ein Debian?
> > - cat /proc/version
> > - lspci -nn | grep -i USB
> > 
> > Und dann mach bitte mal Folgendes:
> > 
> > - USB-Platte raus
> > - tail -fn0 /var/log/syslog
> > - USB-Platte rein
> 
> Hallo Martin, hier die gewünschten Infos - hoffe Du kannst mir
> weiterhelfen (ein paar Mal wurde die Platte inzwischen als USB2.0
> angesteuert, jetzt wieder nicht mehr....?!)
> 
> --------------------------------------------------------------------
> 
> cat /proc/version:
> 
> Linux version 2.6.32-5-686 (Debian 2.6.32-39) (dannf@debian.org) (gcc
> version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Thu Nov 3 04:23:54 UTC 2011
> 
> lspci -nn | grep -i USB:
> 
> 00:1d.0 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW
> (ICH6 Family) USB UHCI #1 [8086:2658] (rev 03)
> 00:1d.1 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW
> (ICH6 Family) USB UHCI #2 [8086:2659] (rev 03)
> 00:1d.2 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW
> (ICH6 Family) USB UHCI #3 [8086:265a] (rev 03)
> 00:1d.3 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW
> (ICH6 Family) USB UHCI #4 [8086:265b] (rev 03)

Es gibt einen USB 2 fähigen Controller:

> 00:1d.7 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW
> (ICH6 Family) USB2 EHCI Controller [8086:265c] (rev 03)

Und mit dem Intelzeugs hab ich auch noch nie Probleme gehabt.

Schau doch mal, ob udev die Module richtig geladen hat. Beispiel:

merkaba:~> lspci -nn | grep -i usb
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series 
Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 04)
00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series 
Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 04)

merkaba:~> ls -1d /sys/bus/pci/drivers/ehci_hcd/00*
/sys/bus/pci/drivers/ehci_hcd/0000:00:1a.0
/sys/bus/pci/drivers/ehci_hcd/0000:00:1d.0

merkaba:~> ls -1d /sys/bus/pci/drivers/uhci_hcd/00*
ls: Zugriff auf /sys/bus/pci/drivers/uhci_hcd/00* nicht möglich: Datei oder 
Verzeichnis nicht gefunden

Einen UHCI Host Controller hat mein ThinkPad nicht:

merkaba:~> lsmod | grep hcd
ehci_hcd               40215  0 
usbcore               124095  3 usbhid,ehci_hcd

Es sollte bei Dir dann ehci_hcd für 00:1d.7 zuständig sein und uhci_hcd 
für den Rest ;).

> tail -fn0 /var/log/syslog:
> 
> Dec  1 13:31:49 praxispc-dell kernel: [ 1037.912017] usb 1-3: new high
> speed USB device using ehci_hcd and address 5

Da stimmts!

> Dec  1 13:31:49 praxispc-dell kernel: [ 1038.236014] usb 3-1: new full
> speed USB device using uhci_hcd and address 4
> Dec  1 13:31:50 praxispc-dell kernel: [ 1038.380020] usb 3-1: not
> running at top speed; connect to a high speed hub

Da nicht. Und die Anweisung ist auch klar:

"connect to a high speed hub"

Also entweder steckts nicht an einem Highspeed-Port oder es ist ein USB 
1.1-Hub dazwischen. Oder für einen Highspeed-Hub ist ein UHCI-Treiber 
geladen.

Mach doch bitte je einmal lsusb -t mit der Platte, wenn EHCI sie anspricht 
und wenn UHCI sie anspricht und gib die Ausgabe.

> Dec  1 13:31:56 praxispc-dell kernel: [ 1044.691050] EXT4-fs (sdb1):
> warning: mounting fs with errors, running e2fsck is recommended

Und las mal ein fsck.ext4 auf das Dateisystem laufen. Vorzugsweise nach 
einem Backup der Daten oder testweise auf einer Kopie der Platte als 
Datei-Image. Auch der SMART-Status für die Platte wär mal gut oder ob I/O-
Fehler im dmesg auftauchen.

Ciao,
-- 
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7


Reply to: