[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dependencies

Tobias Nissen schrieb:
Aha. Dann liegt die Vermutung nahe, dass APT die Pakete aus dem
Debian-Repository bevorzugt, da diese eine höhere Versionsnummer haben.
Du musst das SerNet-Repository höher prioritisieren, APT-Pinning
genannt. Wie das geht, kannst Du hier nachlesen:

bringt leider nicht viel:

aptitude install k9copy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
  sernet-libsmbclient0 sernet-libwbclient0
The following NEW packages will be installed:
dvd+rw-tools{a} dvdauthor{a} exiv2{a} fam{a} genisoimage{a} ghostscript{a} gs-common{a} gsfonts{a} htdig{a} k9copy kaboom{a} kde-icons-oxygen{a} kdebase-runtime{a} kdebase-runtime-bin-kde4{a} kdebase-runtime-data{a} kdebase-runtime-data-common{a} kdelibs-bin{a} kdelibs5{a} kdelibs5-data{a} khelpcenter4{a} libamrnb3{a} libamrwb3{a} libasyncns0{a} libavcodec52{a} libavutil49{a} libavutil50{a} libclucene0ldbl{a} libcupsimage2{a} libcurl3-gnutls{a} libdirac0{a} libdjvulibre-text{a} libdjvulibre21{a} libdvdnav4{a} libdvdread4{a} libenca0{a} libexiv2-5{a} libfaac0{a} libfaad0{a} libfam0{a} libfreebob0{a} libfribidi0{a} libgd2-noxpm{a} libgomp1{a} libgraphviz4{a} libgs8{a} libgsm1{a} libidn11{a} libilmbase6{a} libjack0{a} liblockfile1{a} liblqr-1-0{a} libltdl7{a} libmad0{a} libmagickcore2{a} libmagickwand2{a} libmodplug0c2{a} libmp3lame0{a} libmpcdec3{a} libmpeg2-4{a} libopenexr6{a} libopenjpeg2{a} libpaper-utils{a} libpaper1{a} libphonon4{a} libpostproc51{a} libpulse0{a} libqt4-dbus{a} libqt4-designer{a} libqt4-network{a} libqt4-opengl{a} libqt4-qt3support{a} libqt4-script{a} libqt4-sql{a} libqt4-sql-mysql{a} libqt4-xml{a} libraptor1{a} librasqal1{a} librdf0{a} libsamplerate0{a} libschroedinger-1.0-0{a} libsdl1.2debian{a} libsdl1.2debian-alsa{a} libsmbclient{a} libsoprano4{a} libstreamanalyzer0{a} libstreams0{a} libsvga1{a} libtalloc1{a} libtwolame0{a} libwbclient0{a} libwmf0.2-7{a} libx264-67{a} libxcb-shape0{a} libxcb-shm0{a} libxcb-xv0{a} libxine1{a} libxine1-bin{a} libxine1-console{a} libxine1-ffmpeg{a} libxine1-misc-plugins{a} libxine1-plugins{a} libxine1-x{a} libxml2-utils{a} libxslt1.1{a} libxvidcore4{a} lockfile-progs{a} mencoder{a} phonon{a} phonon-backend-gstreamer{a} pmount{a} psfontmgr{a} raptor-utils{a} redland-utils{a}
  update-inetd{a} vamps{a}
0 packages upgraded, 115 newly installed, 0 to remove and 0 not upgraded.
Need to get 131MB of archives. After unpacking 274MB will be used.
The following packages have unmet dependencies:
sernet-libwbclient0: Conflicts: libwbclient0 but 2:3.3.6-1 is to be installed. sernet-libsmbclient0: Conflicts: libsmbclient but 2:3.3.6-1 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:

Score is -539

Accept this solution? [Y/n/q/?]


apt-cache policy sernet-libwbclient0
  Installed: 3.2.13-24
  Candidate: 3.2.13-24
  Version table:
 *** 3.2.13-24 0
        501 http://ftp.sernet.de lenny/main Packages
        100 /var/lib/dpkg/status

apt-cache policy libwbclient0
  Installed: (none)
  Candidate: 2:3.3.6-1
  Version table:
     2:3.4.0~rc1-1 0
          1 http://ftp.de.debian.org ../project/experimental/main Packages
     2:3.3.6-1 0
        500 http://ftp2.de.debian.org sid/main Packages
     2:3.2.5-4lenny6 0
        500 http://ftp2.de.debian.org lenny/main Packages
        500 http://security.debian.org lenny/updates/main Packages

Also hat der sernet Pkg auf jeden Fall höhere Prio...


Reply to: