[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sbnc installation: problem mit c++ compiler



Patrick Pfeiffer schrieb:
hi leute

ich habe vor sbnc zu installieren
(http://www.shroudbnc.info/About.aspx), jedoch klappts mit dem c++
compiler nicht.

nachdem ich mir das archiv geholt und entpackt habe:

$ ./configure --enable-ssl
checking for g++... no
checking for c++... no
checking for gpp... gpp
checking for C++ compiler default output file name... b.out
checking whether the C++ compiler works... configure: error: cannot
run C++ compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

$ apt-cache show g++
Package: g++
Priority: optional
Section: devel
Installed-Size: 40
Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Architecture: i386
Source: gcc-defaults (1.50)
Version: 4:4.1.1-15

$ sudo apt-get install g++
Reading package lists... Done
Building dependency tree... Done
[..]
The following packages have unmet dependencies:
  g++: Depends: g++-4.1 (>= 4.1.1-2) but it is not going to be installed
E: Broken packages

$ sudo apt-get install g++-4.1
Reading package lists... Done
Building dependency tree... Done
[..]
The following packages have unmet dependencies:
  g++-4.1: Depends: libstdc++6-4.1-dev (= 4.1.1-21) but it is not
going to be installed
E: Broken packages

$ sudo apt-get install libstdc++6-4.1-dev
Reading package lists... Done
Building dependency tree... Done
[..]
The following packages have unmet dependencies:
  libstdc++6-4.1-dev: Depends: libc6-dev (>= 2.3.6-7) but it is not
going to be installed
E: Broken packages

$ sudo apt-get install libc6-dev
Reading package lists... Done
Building dependency tree... Done
[..]
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch4) but 2.6.1-3 is to be installed
E: Broken packages

libc6 habe ich probiert mit aptitude downzugraden. jedoch läuft clamav
und noch _einiges_ was die libc6-2.6.1 benötigt.

übrigens bekomme ich psybnc auch nicht installiert (zumindest geht die
gui nicht), weil libncurses5-dev benötigt wird was wiederum
libc6-2.3.6.ds1-13etch4 benötigt.

ich bin linux-anfänger und habe ehrlichgesagt noch etwas damit zu
kämpfen die packetverwaltung wirklich zu verstehen. wie gehe ich an
das problem heran?

Hallo,

ersteinmal soll dir gesagt sein, dass du NIEMALS Quellen mischen solltest, da hast du dich nun selber in ein kleines Schlamassel reingeritten.

Dann wollt ich dazu mal noch sagen, dass ich sbnc paketiert habe.
Es befindet sich in diesem Moment in der NEW Queue.
Natürlich wird es NICHT nach Etch kommen, aber wenn es denn in den Pool kommt und sich alles rosig entwickelt, wird es wohl im nächsten Release Lenny aufgenommen.

Ersteinmal solltest du natürlich wieder dein System fitt machen.
Wenn das geklärt wäre, dann empfehle ich dir, mein Paket zu backporten.

Die Quellen findest du hier:
http://packages.linux-dev.org/sbnc_1.2-1.dsc

Wenn ich das nun auch auf die schnelle richtig sehe (nicht getestet), dürfte es sich auch anstandslos ohne Anpassungen auf einem Etch bauen lassen.

--
Mit freundlichem Gruß / With kind regards,
Patrick Matthäi

E-Mail: patrick.matthaei@web.de
Homepage: http://www.Linux-Dev.org/


Reply to: