[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OT: OffBoard Soundkarte mit optischen Digitalausgang für mein Debian oder ne Lösung für ne Soundblaster Karte



Am Samstag, 15. Dezember 2007 schrieb Ingo Witzky:
> Hallo Mitdebianer.
>
> Ich besitze momentan eine Soundblaster Live Platinum 5.1 und bin
> damit eigentlich zufrieden. Allerdings habe ich es seit dem Umstieg
> von OSS auf ALSA (was schon einige Zeit her ist) immer wieder
> versucht den Master-Ausgang (also die Summe aller Quellen auf dem
> Line-Out) auf den optischen Digitalausgang zu legen. Bei dem alten
> OSS ging das einfach so ohne Handanlegen und damals zu den Zeiten von
> Win98 funktionierte das auch (als ich das noch benutzt hab).

Ich hab ein Déjà-vu, die fast gleiche Karte besaß ich ebenfalls über 
einige Jahre mit dem exakt gleichen Problem. 

> Ich habe gegoogelt, Alsa-Wikis gewälzt mich mit dem "ALSA emu10k1/2
> patch loader" alias ld10k1, dem "GUI utility for ld10k1" alias
> qlo10k1 und den alten OSS Tools von Creative beschäftigt. Leider bin
> ich zu keiner Lösung gekommen und habe dabei eine große Menge Zeit
> verplempert.

Ja, das habe ich ebenfalls alles versucht ;)

> Jetzt suche ich nach einer Empfehlung für eine Soundkarte deren
> optischer Digitalausgang unter Debian ohne große Klimmzüge als
> Master-Ausgang genutzt werden kann. Die Lautstärke sollte dann
> natürlich auch via Master im Mixer gesteuert werden können.


Ich verwende jetzt eine
 0 [Audigy         ]: Audigy - Audigy 1 ES [SB0160]
                      Audigy 1 ES [SB0160] (rev.3, serial:0x521102) at 
0x9000, irq 22

und bin damit zufrieden. Der Master Regler regelt auch die SPDif 
Lautstärke.
LD10k1 verwende ich immernoch, allerdings nur, um noch zusätzlich einen 
Master-Mute Switch [und einige andere die ich eigentlich nicht brauche] 
zu bekommen, der steht bereits in dem init_audigy Script, ist aber 
auskommentiert.

Eins muss ich dazu noch anmerken, AC3-Pass-thru funktioniert (bei mir) 
nicht per default. Das Problem ist, im Kernel ist für diesen Kartentyp 
(also sb0160) der spdif_bug aktiviert (== vertauschte spdif-Kanäle) was 
für diese Karte allerdings nicht zutrifft. Ein Bugreport existiert dazu 
bereits:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2866
es reagiert aber niemand drauf. Daher Patche ich immer selbst meine 
Kernel. 

> Oder hat vielleicht Jemand von Euch vielleicht eine Lösung für mein
> Problem?

Ich glaube ohne tiefe Programmierkentnisse des emu10k1 wirst du hier 
nicht weiterkommen.
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=394

Grundsätzlich sind die emu10k1 Karten nicht schlecht, leider 
unterscheiden sie sich in kleinen Details die auch teilweise im Treiber 
nicht korrekt unterschieden werden. Daher kann man eine grundsätzliche 
Empfehlung für emu10k1 Karten eigentlich nicht aussprechen. Mit obiger 
Audigy 1 ES bin ich jetzt auf jeden Fall zufrieden. 

-- 
Markus Schulz

Kreuzigt mich - aber Debian ist einfach deppensicher.
Es lässt Deppen gegen eine Wand von Schwierigkeiten klatschen und
langsam abtropfen. Wer die Tür findet, darf mitspielen - und so sieht
das Spielzeug dann eben aus: Gut gepflegt. -- Joerg Rossdeutscher


Reply to: