[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Etwas OT: Probleme mit PHP5-PECL-Erweiterung gnupg und gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)



Hallo,

meine Frage ist hier etwas OT, aber in der PHP-Newsgroup hat sich leider keine Lösung ergeben. Deswegen frage ich hier mal nach, ob jemand das Problem kennt und eine Lösung weiß.

Ich möchte unter PHP5 auf einem Debian Lenny/testing die PECL-Erweiterung gnupg installieren. Ein pecl install gnupg scheitert jedoch im make mit ca. 100 Fehlermeldungen. Ein Auszug:

In file included from /gnupg.c:22:
/php_gnupg.h:35: error: expected specifier-qualifier-list before 'gpgme_ctx_t'
In file included from /gnupg.c:25:
/php_gnupg_keylistiterator.h:37: error: expected specifier-qualifier-list before 'gpgme_ctx_t'
/gnupg.c: In function 'gnupg_free_encryptkeys':
/gnupg.c:93: error: 'gnupg_object' has no member named 'encrypt_size'
/gnupg.c:94: error: 'gnupg_object' has no member named 'encryptkeys'
/gnupg.c:100: error: 'gnupg_object' has no member named 'encryptkeys'
/gnupg.c:101: error: 'gnupg_object' has no member named 'encryptkeys'
/gnupg.c:102: error: 'gnupg_object' has no member named 'encrypt_size'

So geht das dann ewig weiter. Unter Etch habe ich leider das gleiche Problem.

Hat jemand von euch schon mal gnupg unter Lenny/Etch erfolgreich installiert und kann mir eine Lösung für das Problem nennen?

Grüße,

Alex



Reply to: