[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Hohe CPU-Last bei Netzwerkaktivität



Hallo,

ich kämpfe bei meinem Debian Sid (Vanilla-Kernel: 2.6.18) mit dem
Problem, dass z.B. bei einem FTP-Transfer das System so stark
ausgelastet wird, dass der Rechner fast nicht mehr zu benutzen ist
(ähnliches gilt für das Update der Paketliste).

Im Rechner ist eine Netzwerkkarte mit Atheros-Chipsatz verbaut. Der
Kernel bzw. die Treiber scheinen nicht das Problem zu sein, da es mit
Kernel 2.6.15 und älteren Treibern ebenso auftrat.

Ich vermutete erste einen IRQ-Konflikt (ACPI, APIC sind übrigens
aktiviert), weil die Netzwerkkarte und der Grafikkarte sich einen IRQ
Teilen mussten. Nun hat jeder einen IRQ für sich, aber trotzdem besteht
das Problem noch immer.

"cat /proc/interrupts" lierfert:
           CPU0
  0:     869095    IO-APIC-edge  timer
  1:       7147    IO-APIC-edge  i8042
  8:        237    IO-APIC-edge  rtc
  9:          0   IO-APIC-level  acpi
 14:      65164    IO-APIC-edge  ide0
 15:         37    IO-APIC-edge  ide1
 16:     270789   IO-APIC-level  mga@pci:0000:02:00.0
 17:          2   IO-APIC-level  ehci_hcd:usb3
 18:     124364   IO-APIC-level  wifi0
 19:      30426   IO-APIC-level  ohci_hcd:usb1, NVidia nForce2
 20:          0   IO-APIC-level  ohci_hcd:usb2
NMI:          0
LOC:     868998
ERR:          0
MIS:          0

Was auffällig ist, dass kurz nach dem Start des Downloads die wait-time
nach oben geht, d.h. der Kernel wartet zu 90-100% nur auf die Daten der
Netzwerkkarte.

Beim Booten kommen jede Menge Meldungen der folgenden Art (weiß nicht,
ob das wichtig ist):
ACPI: PCI Interrupt Link [APCF] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCG] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCH] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCI] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCJ] (IRQs 20 21 22) *0, disabled.
ACPI: PCI Interrupt Link [APCK] (IRQs 20 21 22) *0, disabled.

Und außerdem:
PCI: Bridge: 0000:00:08.0
  IO window: disabled.
  MEM window: e9000000-e9ffffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1e.0
  IO window: disabled.
  MEM window: e6000000-e8ffffff
  PREFETCH window: e4000000-e5ffffff


Die Frage ist nun: Mit welchen Tools kann ich die Ursache des Problem
weiter eingrenzen?


Viele Grüße
Marco

PS: Das Board ist ein Epox 8rda+ mit nforce2-Chipsatz.



Reply to: