[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel-Panic wg nicht gefundenem /



Hallo Debian-Liste,

nach laengerem (mehrere Jahre) fremdgehen bin ich wieder bei Debian
gelandet. 

Folgende Situation: auf meinem Laptop (IBM ThinkPad X24) laeuft ein
FreeBSD 6.1 als eigentliches Arbeitssystem. Aber auf einem freien Rest
(ca. 7GB) am Ende der Platte wollte ich ein Debian Sarge packen. Am
Beginn der Platte befindet sich noch eine freie Partition (ca750 MB),
die als DOS (SysID 0x06) gekennzeichnet ist (soll mal eine
Hibernate-Partition werden). Beide, die DOS wie auch das
FreeBSD-Slice, sind primaere Partitionen; das FreeBSD-Slice enthaelt
die FreeBSD-Partitionen - insgesamt 6.

Mit dem Debian-Instaler habe ich in dem freien Platz am Ende drei
logische Partitionen angelegt:

200 MB (ext3) fuer /
500 MB Swap
6.4 GB LVM fuer /usr /var /usr/local und /home (jeweils xfs)

Die wurden auch mit Nr. 5, 6 und 7 bei der Partitionierung im
Installer durchnummeriert. Ich schliesse daraus, das sie hda[567]
heissen.

Als Boot-Loader habe ich Grub verwendet, wobei ich den von FreeBSD in
den Ports angebotenen nehmen muss, da der Linux-Grub kein ufs
unterstuetzt (warum eigentlich? BTW, der Installer erkennt das
FreeBSD-Slice auch nicht und ist der Meinung, Debian sei das einzige
installierte System - fragwuerdig). Das hat auch den Vorteil, dass
menu.lst auf FreeBSD liegt - und sieht wie folgt aus:

timeout 30
default 0
#
title FreeBSD 6.1
root (hd0,1,a)
kernel /boot/loader
#
title Debian Sarge
root (hd0,4)
kernel /vmlinuz root=/dev/hda5

Das bootet FreeBSD (natuerlich). Aber wenn ich Debian booten will,
erhalte ich eine Kernel-Panic wegen nicht gefundenem Root, obwohl ich
dieses explizit mit "root=..." angebe.

Die Frage ist jetzt, warum? Den Kernel findet er ja auf der angebenen
Partition (OK, das regelt noch der Grub). Die Zaehlung ist also
korrekt (habe ich auch am Grub-Prompt ueberprueft). Aber
offensichtlich findet der Kernel nicht weiter.

Bei der Debian-Installation habe ich natuerlich den Grub nicht mehr neu 
installiert (BTW: bei dem normalen Ablauf im Installer hat man diese
Moeglichkeit eigentlich nicht; ich lasse die Eintragszeile leer und er
bricht ab; ich hab dann im Installer noch die Installation
vervollstaendigt; das Grundsystem ist also komplett installiert).

Viel Text, sorry dafuer, und ich hoffe ich hab jetzt alle Infos
mitgliefert (nachliefern kann ich natuerlich immer noch was).

Die Frage ist, was ist passiert? Und viel wichtiger, was muss ich tun,
um nach Jahren wieder mal mit Debian spielen zu koennen?

Dankbar fuer jeden Tipp,

Karsten


-- 
                                                       
Karsten Rothemund <karsten@photor.de>     /"\
PGP-Key:     0x7019CAA5                   \ /
Fingerprint: E752 C759 B9B2 2057 E42F      \  ASCII Ribbon Campaign
             50EE 47AC A7CE 7019 CAA5     / \ Against HTML Mail and News

Attachment: pgpeg3S241mce.pgp
Description: PGP signature


Reply to: