[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Courier pop3-ssl



Am Mittwoch, 30. August 2006 14:37 schrieb Evgeni Golov:
> On Wed, 30 Aug 2006 14:20:20 +0200 Andreas Hergesell

> > > Dann mach doch das POP3_TLS_REQUIRED aus ;-)
> >
> > Naja, ich würde aber eben gerne meine User zwingen über SSL zu
> > poppen.
>
> [ ] du hast das Manual gelesen ;-)

Hmm, doch. Sowas mache ich immer zuerst, aber da ist mir wohl was 
durchgegangen.
Werde ich mir nochmal zu Gemüte führen.

> Wenn du deine User zum ssl-poppen (perverse Sache das) zwingen

Safety first! :-)

> willst, starte courier-pop3 nicht, sondern nur courier-pop3-ssl.
> Dann können die nicht mehr auf Port 110 verbinden, sondern nur
> auf 995, und da ist SSL Pflicht - mit TLS hat das an der Stelle
> nichts zu tun.

Ich dachte die wären voneinander abhängig, also ohne pop kein 
pop-ssl und
wenn POP3_TLS_REQUIRED gesetzt ist bekäme man bei einem Versuch auf 
110 ein Login_disabled.


> Hast du denn deinen Client auch drauf angewiesen, explizit SSL zu
> nutzen? Den meisten muss man das unter androhung der
> Deinstallation erklären, weil die das sonst ned raffen ;-)

Naja, das Häkchen "Use secure connection (SSL) ist gesetzt. Und dann 
wird der Port automatisch auf 995 geändert.

Mit Kmail geht es wohl auch nicht. Kmail versuchte es auf Port 110. 
Und da gings. Auf 995 gehts auch nicht.


>
> Probier mal bitte folgendes:
> # openssl s_client -host dein.mail.de -port 995
>
> Kommt da als letzte Zeile "+OK Hello there." ?

Ja.
[schnipp]
+OK Hello there.
CAPA
+OK Here's what I can do:
SASL LOGIN PLAIN CRAM-MD5 CRAM-SHA1
STLS
TOP
USER
LOGIN-DELAY 10
PIPELINING
UIDL
IMPLEMENTATION Courier Mail Server
.
USER
-ERR TLS required to log in.
quit
+OK Better luck next time.
closed

> Hier tut das nämlich und ich kann mich per SSL einloggen.
>
> > Meine Konfiguration sieht so aus:
> >
> > [14:14]server:/etc/courier# grep -v "#" pop3d
> >
> > PIDFILE=/var/run/courier/pop3d.pid
> > MAXDAEMONS=40
> > MAXPERIP=10
> > AUTHMODULES="authdaemon"
> > AUTHMODULES_ORIG="authdaemon"
> > DEBUG_LOGIN=0
> > POP3AUTH="LOGIN PLAIN CRAM-MD5 CRAM-SHA1"
> > POP3AUTH_ORIG="LOGIN PLAIN CRAM-MD5 CRAM-SHA1"
> > POP3AUTH_TLS="LOGIN PLAIN CRAM-MD5 CRAM-SHA1"
> > POP3AUTH_TLS_ORIG="LOGIN PLAIN CRAM-MD5 CRAM-SHA1"
> > PORT=110
> > ADDRESS=0
> > TCPDOPTS="-nodnslookup -noidentlookup"
> > POP3DSTART=YES
>
>              ^^^ NO # du willst ja SSL-only

Da das im Moment ja noch nicht klappt, brauche ich den pop3d schon.

>
> > MAILDIRPATH=Maildir
> >
> > [14:14]server:/etc/courier# grep -v "#" pop3d-ssl
> >
> > SSLPORT=995
> > SSLADDRESS=0
> > SSLPIDFILE=/var/run/courier/pop3d-ssl.pid
> > POP3DSSLSTART=YES
> > POP3_STARTTLS=YES
> > POP3_TLS_REQUIRED=0
> > COURIERTLS=/usr/bin/couriertls
> > TLS_PROTOCOL=SSL3
> > TLS_STARTTLS_PROTOCOL=TLS1
> > TLS_CERTFILE=/etc/courier/pop3d.pem
> > TLS_VERIFYPEER=NONE
> > TLS_CACHEFILE=/var/lib/courier/couriersslcache
> > TLS_CACHESIZE=524288
> > MAILDIRPATH=Maildir
>
> Sieht bei mir so aus:
> prefix=/usr
> exec_prefix=/usr
> SSLPORT=995
> SSLADDRESS=meine.ip
> SSLPIDFILE=/var/run/courier/pop3d-ssl.pid
> POP3DSSLSTART=YES

Bei dir fehlt POP3_STARTTLS=YES.
Wenn ich das bei mir rausnehme ändert sich leider nix.

> POP3_TLS_REQUIRED=0
> COURIERTLS=/usr/bin/couriertls
> TLS_PROTOCOL=SSL3
> TLS_STARTTLS_PROTOCOL=TLS1
> TLS_CERTFILE=/etc/courier/pop3d.pem
> TLS_VERIFYPEER=NONE
>
> > Irgendwie klappts nicht :-(
>
> Hier schon ;-)
Er fragt also nicht nach einem zusätzlichen STLS?
>
> Gruß

Viele Grüße

Andreas



Reply to: