[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

error: failed dependencies: mozilla & java/j2re1.5.0/plugin



hallo,

ich wollte (will) jre als mozilla-plugin
installieren (mit rpm, wobei ich nicht weiss, ob
diese installationsmethode wirklich schlau ist)
und habe untenstehende fehlermeldung und weiss
nicht recht weiter. es gibt wohl die option
-nodeps (und -force?) aber die scheint mir gefährlich.

ich habe mich bei allem genau an die anleitung auf

http://www.debian.org/doc/manuals/debian-java-faq/ch8.html
8.4 Can I use Java in Mozilla?

gehalten. mein mozilla ist ein

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040413 Debian/1.6-5

und die outputs der befehle

c++filt -s gnu __vt_17nsGetServiceByCID
objdump -R /usr/lib/libxpcom.so | grep
nsGetServiceByCID
c++filt -s gnu-v3 _ZTV17nsGetServiceByCID

sind exakt so, wie unter "8.4 Can I use Java in
Mozilla?" angegeben. per apt-get install hatte ich
mir vorher binutils und rpm geholt. ausserdem
hatte ich in /var/lib/ ein verzeichnis /rpm angelegt.

gemäß
http://plugindoc.mozdev.org/faqs/java.html
habe ich den befehl
ln -s
/usr/java/j2re1.5.0/plugin/i386/ns7/libjavaplugin_oji.so
gegeben und damit wohl den symbolischen link angelegt.

gemäß der installationsanweisung
http://java.sun.com/j2se/1.5.0/jre/install-linux.html
habe ich dann in mein /hjs homeverzeichnis die datei
jre-1_5_0-linux-i586-rpm.bin geladen und mit dem
befehl
chmod a+x jre-1_5_0_<version>-linux-i586-rpm.bin
die dateirechte geändert.

danach habe ich dann versucht zu installieren mit
rpm -iv jre-1_5_0-linux-i586.rpm
was zunächst wohl primär deshalb fehlschug, weil
das verzeichnis /rpm nicht existierte, welches ich
dann aber -wie oben beschrieben- angelegt habe.

danach habe ich den installationsbefehl erneut
abgesetzt und hänge jetzt an der genannten
fehlermeldung. und hier ist sie:

"...run on the Java 2 Platform Standard Edition
(J2SE platform) platform
on Java-enabled general purpose desktop computers
and servers.

Do you agree to the above license terms? [yes or no]
y
Unpacking...
Checksumming...
0
0
Extracting...
UnZipSFX 5.42 of 14 January 2001, by Info-ZIP
(Zip-Bugs@lists.wku.edu).
replace jre-1_5_0-linux-i586.rpm? [y]es, [n]o,
[A]ll, [N]one, [r]ename: y
  inflating: jre-1_5_0-linux-i586.rpm
error: failed dependencies:
        glibc >= 2.1.2-11 is needed by jre-1.5.0-fcs
        sh-utils >= 2.0-1 is needed by jre-1.5.0-fcs
        fileutils >= 4.0-8 is needed by jre-1.5.0-fcs
        gawk >= 3.0.4-1 is needed by jre-1.5.0-fcs
        textutils >= 2.0-2 is needed by jre-1.5.0-fcs
        /bin/sh   is needed by jre-1.5.0-fcs
        /bin/sh   is needed by jre-1.5.0-fcs
        /bin/sh   is needed by jre-1.5.0-fcs

Done."

hätte jemand einen vernünftigen tip, was ich tun
soll?!

gruss
lucas

This message was sent from the free private e-mail service by easy.com, the portal site owned by Stelios and the easyGroup. This email service is available to all members of the public to use for personal reasons only.  Not all subscribers to this e-mail service are representatives of an easyGroup company.



Reply to: