[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

getmail: bei Zustellung an Postfix wird amavis ignoriert



Hello,

ich bin gerade dabei fetchmail durch getmail zu ersetzen (weil
eben fetchmail öfters beim downloaden von Spam Nachrichten hängen
bleibt)

Server:
Postfix (2.1)
Getmail (3.2.2)
spamassassin (2.63)
amavis-new (0.20030616)
SA + amavis werden direkt über die master/main.conf eingebunden.

Verhalten unter fetchmail:
Mail wird abgeholt, Postfix zugestellt, der scannt auf Spam und Viren und
legt das mail via procmail unter /var/spool/mail ab.

Verhalten unter getmail
Mail wird abgeholt, mit postmaster = '|/usr/sbin/sendmail -i -f "$SENDER"
mailbox' an postfix zugestellt, dann auf Spam gescannt und unter
/var/spool/mail abgelegt --- aber *nicht* auf Viren gescannt.

Warum, wieso, weshalb? ;) Ich kann mir das nicht so ganz erklären.

*master.conf(auszug)*
smtp    inet    n       -       y       -       -       smtpd
pickup  fifo    n       -       y       60      1       pickup
 -o content_filter=
 -o receive_override_options=

#amavis-new
127.0.0.1:10026 inet    n       -       y       -       -       smtpd
 -o content_filter=
 -o smtpd_restriction_classes=
 -o smtpd_client_restrictions=
 -o smtpd_helo_restrictions=
 -o smtpd_sender_restrictions=
 -o smtpd_recipient_restrictions=permit_mynetworks,reject
 -o mynetworks=127.0.0.0/8
 -o mynetworks_style=host
 -o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
 -o smtpd_client_connection_limit_exceptions=127.0.0.0/8

lmtp-filter     unix    -       -       y       -       -       lmtp
 -o lmtp_data_done_timeout=1200
 -o disable_dns_lookups=yes

smtp-filter     unix    -       -       y       -       -       smtp
 -o smtp_data_done_timeout=1200
 -o disable_dns_lookups=yes

#spam Assassin
filter    unix  -       n       n       -       -       pipe
   user=filter argv=/home/filter/sc/filter.sh -f ${sender} -- ${recipient}


*main.conf(auszug)*
content_filter = lmtp-filter:127.0.0.1:10025


vielleicht kann mir ja wer nen Tipp geben,

Vielen Dank,
patrick



Reply to: